Playback and zone switching issues

I checked with Netflix the device output sound fine. Roon says its playing to that zone but music is not coming out.

Update on this. I went to the main computer and started an album in the Apple TV zone and it played no problem. But when it was over and auto switched to radio, no output.

I can’t stream to my apple tv either

and it does not appear in the zones menu, even though it is enabled and on the same network

Further updates. This is apple TV 3. Very buggy behavior. I play an album and it plays, but when it switches over to radio, it SHOWS tracks playing, but no sound is coming out of the VERY SAME STEREO that was just playing. I use all caps not to shout, but to emphasize that nothing about the system setup Roon is running on has outwardly changed.

Also, it doesn’t seem to like starting tracks from the Roon app on my iPad. Sometimes it does and sometimes it doesn’t. On the other hand, going downstairs to my music room and starting tracks there (for the apple tv upstairs) is a crapshoot as well. Sometimes tracks will start, sometimes they won’t. Usually, but not always, clicking the forward button will get a track playing. But then the next one is back to silence.

I haven’t used Roon downstairs since i got my library all in (I had huge problems there initially) so I don’t know if its behavior on the main system is any better, but I plan to try later.

Hi David,

Let’s leave a notification for @mike and @vova to investigate.

It will assist if you can set out details of your setup and network so that known issues can be identified or ruled out.

There are three behaviors I have experienced that I am hoping to find help with here:

1 (the biggy) - Roon “says” a song is playing, but nothing is coming out of the stereo. This happens in both my zones.

2 - Roon seems to be very finicky about switching zones. The only way I have been able to get a new zone playing is by switching zones on the Mac Mini Roon resides on AND starting a song in my new zone. Then the remote app on the iPad works, but if I try to control everything from the iPad, it goes back to problem 1, above.

3 - Several times during listening sessions, Roon has quit its output in the middle of a listening session. This happened last night after I thought I was running pretty smoothly, and that was the most annoying instance, but it also happened several times when my wife and I were listening upstairs (Apple TV zone).

I don’t think there is anything too unusual about my setup, but here it is:

Roon resides on an i5 Mac Mini with a 2.6 GHz processor, it is now running the newest OSX, El Capitan, version 10.11.1. iTunes is also current and I do have “share xml” checked. The library resides on a LaCie rugged 1TB firewire drive, in two folders, iTunes and Untitled. The mini is connected via USB to a built in DAC in my preamp, a Parasound P5. Upstairs, I have a 3rd generation Apple TV connected via HDMI to a Denon AVR. I have two zones activated in Roon, P5 and Apple TV.

Any help with these issues would be greatly appreciated.

Hi David and Steve,
I’ve merged the posts, closed the other one and retitled this thread. That way the devs can concentrate on the problem, rather than the forum. Support will see the notification in this thread with David’s system details and should be in touch with you both shortly.

If Steve could provide similar system details that will assist investigations.

Andrew, thanks for your help here. I have one piece of information I forgot. It could be important and I’ll be doing some more investigating. I have 16 gigs of RAM, but it’s aftermarket and about this Mac shows 8. I know there is another way in the Mac system to see how much RAM your OS actually has available. More RAM is almost always better.

Thanks David, that sounds like your system isn’t seeing all your RAM. That can lead to chaotic effects. I’d suggest firstly checking to see that all RAM modules are firmly seated, maybe use some Deoxit on the edge connectors.

If that doesn’t result in all RAM being read then you may have a faulty RAM module. Pull them successively until you find the culprit (make a warranty claim on it). Then check Roon again, 8Mb should be enough to check if your playback issues are continuing.

Well sorry Andrew, but that was dead end. I was wrong, I only have 8 GB RAM, and it is being seen. I looked at your hardware recommendations, and I am right in you guys’ wheelhouse. I have a late 2012 i5, 2.5 GHz processor, 8 GB RAM, 56(ish) GB SSD, only half full, with a 1 TB Firewire Drive. I have the newest iTunes and the newest OSX. My album collection is around 1500 albums, maybe even less.

What’s my next step to diagnose these issues? The biggest is the no output behavior, next is the stopping in the middle of a listening session.

Next is not being able to just start and run the app with the iPad app. I keep the app running all the time so when I want it I should only have to reach for the iPad, but that doesn’t seem to be working. Is that approach a reasonable expectation, or is the iPad app still a work in progress?

Hi David,
Let’s leave a notification for @mike and @vova to investigate further. I expect they will be in touch shortly to gather some loga which will help show what is going wrong here.

@andybob @mike and @vova I think I have some headway on my issues! I think the files that are causing me grief are flacs resident in my iTunes library that have a bookmark created by PureMusic to allow it to run them in iTunes. Flacs in the untitled folder, which don’t have these bookmarks, aren’t affected.

I took one of the albums and deleted the bookmark, leaving the album in my iTunes folder. It still wouldn’t play, and the behavior got weirder. It said “playing 11 tracks” but the status bar at the bottom of the screen never appeared.

Next I moved the album to the untitled folder and restarted the mini. Found the album and it played! One glitch though, the Roon library management system now thinks I have two copies, even though I moved the album, so there’s only one copy of all the tracks that make up the album on the computer, and it’s in my untitled folder.

So, I’m pretty sure that’s the reason for the silence. Last night I played a bunch of stuff on Tidal, and some of my albums, which must have been either ALACs or the FLACs that are in the untitled folder. That’s a reasonable supposition, since most of my albums are ALACs. When I decided to play Nanci Griffith, silence. She’s in FLAC in the iTunes folder with a bookmark provided by PureMusic.

So, I’m pretty sure that’s the issue, but I’m not sure what to do about it. I’m not sure I’m ready to take the step of just moving all those albums to a new folder and getting rid of the PureMusic bookmarks. You guys all know that I do like a lot about your software, but if I decide not to purchase that’s a lot of redoing of my PureMusic bookmarks I’d have to do.

If you have any ideas I’d love to hear them. I can’t be the first guy to have an iTunes library he runs in conjunction with PureMusic who has FLACs in the library with PureMusic bookmarks, can I? Maybe I am, I don’t have a clear picture of how many people go beyond just running iTunes on a Mac. I probably wouldn’t have if not for all the FLACs that I didn’t want to deal with converting. Seemed like an easy answer at the time to just run PureMusic so I could leave them in FLAC format.

Hey @david_burnside – sorry for the slow response here. I know you sent me a PM as well, and I’ll be getting back to you there shortly as well.

I have to confess I’m not familiar with PureMusic, but I can do a little research. For now, we may be able to work around the iTunes issues by pointing Roon at your files directly. The only downside would be that if you’ve made a lot of playlists in iTunes, they wouldn’t be imported into Roon yet. Let me know if that’s an issue for you.

So, if you’re ok with taking iTunes out of the mix for a minute, why don’t you try this – you can also try it as a temporary solution while I look into what might be happening with PureMusic:

  • Go to the Storage tab of Settings
  • Next to iTunes, click the Gear and select Disable
  • Next to Watched Folders, click the button that says Add Folder
  • Add the Firewire drive, or the folder where you keep your music files
  • Roon will begin importing your music and retrieving detailed metadata (Note: this can take some time, and Roon may run a bit more slowly than normal until the initial import is completed)

This should give Roon direct access to any files we support, and should get you up and running without requiring you to change you configuration.

Let me know if that helps here, and I’ll talk to you soon David!

I’ll try that tonight.

I tried it this morning before work. I’d say it took care of 95% of my problems. It sees the files that used to be “PureMusic flacs” as dups. I set Roon to not show hidden albums, so for now at least I don’t see them. Unfortunately, Roon is also hiding some of my remasters, etc.

I wonder if a clean install (delete Roon and get it again from my downloads folder) would get rid of all those (not really there twice) dups? It seems like a bad idea to let the software manage nonexistent files.

I have a couple other smaller issues but I’m going to wait to hear back from you guys about my idea for a clean install. Maybe that will deal with my other issues too. If not I’ll post separately about them.

You’re seeing these duplicates even with iTunes disabled in your Storage settings? What if you disable your Music folder?

I am. I moved everything out of the iTunes folder. I never really used iTunes the way Apple intends. I had one giant music folder inside the iTunes folder. For me iTunes was never more than a ripper/organizer. All I had to do was move one folder out of the larger iTunes folder to the root level on the LaCie.

What do you think of my idea to reinstall Roon?

If you haven’t made any edits or generated any data in the app you want to preserve (like playlists or favorites), I think it’s a good idea.

Just go ahead and delete (or rename) the Roon database (located here) and reinstall – you’ll log in and start totally fresh. Let me know how it goes David!

Wow, I think I’m good! Thanks to the whole staff for your help in figuring this out. The fact that I was a little under the weather when I first tried installing Roon got me off on a grumpy foot, I’m quite sure I was not an ideal customer early on.

It looks to me like my problems were all related to the difference in the way PureMusic interacts with the Mac vs. the way Roon does. I’ll try to explain, and there may be gaps. I do think you guys might want to have me send you some .pmbmf files to look at.

PureMusic runs with iTunes as its organizer. In order to play FLACs, it has to have the user generate a bookmark that it uses to basically fool iTunes into thinking the album is an ALAC so it can see it and organize it. PureMusic claims they are playing your files, and I am not a coder so I can’t argue, but looking at the way they do this now it sure seems like they have iTunes involved in the playing process somehow.

When I first loaded Roon and had it look at my music, there were huge gaps. Looking back, it’s pretty clear to me that they were all involving the FLACs stored in my iTunes library with bookmarks. Some albums showed up partially, some not at all.

I updated my iTunes which allowed me to share its .xml file, which finally got all the albums to show up, but now the FLAC albums wouldn’t play. Roon said they were playing, but there was no sound coming from the system. I still didn’t connect this to the fact that these were my FLAC files. It’s one of those things that’s obvious in retrospect, but until you get there the behavior can be quite mysterious.

Eventually I did notice that the funny playing behavior was related to my FLACs with .pmbmf extensions associated with them. I moved one of the albums to a different folder but it still wouldn’t play. Then I took the entire “music” folder out of the iTunes folder and restarted my system, and got all the files to play. I did see duplicates for all the FLAC files that were formerly in iTunes though. This is when I deleted my library and reloaded Roon.

Which brings us to now. I still see the duplicates, but I know what they are. Roon is seeing the .pmbmf files as albums, and calling them duplicates. I’m slowly telling it to remove the duplicates.

I believe the .pmbmf files were the cause of all my problems. They are still there, but now that I have reloaded everything and taken my music out of the iTunes folder, they don’t seem to cause Roon confusion any longer.

As a huge bonus, all my other issues seem to be resolved too. I can switch seamlessly between zones, start the radio, etc.

I think having non-iTunes formatted files in an iTunes folder with those PureMusic bookmark files is what flummoxed Roon, and it did it in many ways. It seems happy with them in a generic “music” folder. I’m removing the duplicates, but I believe since it’s a watched folder, not an organized folder, I’m removing them from Roon is only removing them from it’s library. I have not confirmed yet, but I’m pretty sure I’m right. There’s no real reason to want them assuming I keep Roon, which I am 99.99 percent sure I will, but I also can’t see any reason to get rid of them either, in case I ever do want to resurrect PureMusic.

Anyway, thanks guys for your patience and your part in helping me figure out what I was doing wrong. If you want to take a look at these .pmbmf files I will be happy to send you some. Convincing Roon to ignore them, as they are not actually music files, would probably be best, but I also realize it’s probably not a huge priority for your development team. Something to think about anyway.