Playback breaks when switching sample rate (Metrum DAC)

I’ve got 6 or 7 Roon endpoints in my system, of which 3 are Raspberry Pi devices as follows:

Raspberry Pi->USB cable->Metrum Onyx DAC
Raspberry Pi->USB cable->Chord 2Qute DAC
Raspberry Pi->Hifiberry DAC+ XLR

I’ve noticed that sometimes when changing track/album, the Pi using the Metrum DAC emits a brief burst of white-ish noise, and then refuses to play. The playback progress continues to move, but there is no sound out of the DAC. If I pull out the USB cable, and plug it back in again, the Metrum Pi starts working again.

I’ve noticed that I can switch between tracks that are all redbook, or high res flac, or even DSD, but if I then switch to MP3 the problem occurs. Similarly, if I’m listening to MP3 and switch back to redbook or high res flac, the problem happens.

This problem only seems to occur with the Metrum DAC. I believe it’s 100% reproducible, which is good I guess. Are there logs I can produce that will help to diagnose this, or is it going to be something I need to take up with Metrum?

Try changing Resync Delay under Device Settings,

1 Like

I have the same issue on my Arcam irDac iI via usb. Support could not help and said it must be the DAC and Linux as its fine using windows and same DAC via uab It did it using my Allo bridge and running Ropieee. I have to have upsampling enabled to make it work. The delay had no effect at all. It only happens when switching to MP3 or AAC that Roon is upsampling to 24bit by default. Going the other way or anything else is fine

1 Like

Thanks guys.

I tested resync delay of 7 second (!) and it didn’t fix the problem alas. Thanks for the idea @Martin_Webster

My situation matches @CrystalGipsy exactly. I’ve been on a mission to re-rip the MP3 in my collection to FLAC but it’s a huge task and will take me years probably to locate all the CDs that haven’t been reencoded.

I would be happy if @support could suggest something I can do within Roon to reinitialise the audio device. Having to get up out of my chair, reboot the Pi, and wait the 20 seconds or so is an inconvenience.

Not sure if you’ve tried but I can play the files when started from stop it’s only when you hit one in a playlist it’s an issue or you skip to one in a playlist.

Here’s my post with same issue.

1 Like

Thanks @CrystalGipsy it seems like you’ve done all the work. I am very grateful. My situation is absolutely and exactly the same as yours. If I hit stop in between flac and mp3 playback, it works fine. That helps me a bit.

It also means that Roon should be able to fix this without blaming Linux+DAC right? If the resync delay did the equivalent of a stop and a play, that would sort it.

I don’t really fancy having upsampling or volume levelling turned on all the time.

Yeah I don’t remember it doing this until they introduced the 24 bit upsampling to low-res content. It’s also no easy to test other software to see if they do the same as I don’t have any 44.1khz 24 bit files. I guess I could make one from an MP3 and see if that works. It would highlight if it’s just Roon or a Linux comparability thing.

1 Like

Just created a sample 44.1 24bit file and the dac stil falls over when Roon switches to it, so it’s not the live upsampling causing the issue.

Tried the same in MPD and no issues, So this is Roon related.

1 Like

Hi @wintoid, thank you for the report and sharing this observation you have made with us while using the Metrum DAC with Roon. Very appreciated!

Moving froward, I would like to enable diagnostics on your account so we can have a closer look into this behavior. However before I enable this feature may I very kindly ask you to please reproduce the issue and note the time that it occurred along with what track/album was being played.


I’ve just forced this to happen just now at 10:28 29th August 2018

CD quality - Bassomatic - In the realm of the senses
MP3 - Bassment Jaxx - Rendez-vu

After it crashed, I went back to try to play the Bassomatic track again, and it started cycling through the tracks on the album, failing to play them, one by one.

Let me know if you need more.



Thanks for the follow up @wintoid and providing the requested information :sunglasses:

Now that I have a sense as to when the issue occurred I will be enabling the mentioned diagnostics on your account. What this action will do is the next time Roon is active on your core machine a diagnostics report containing a set of your Roon logs will be automatically be generated/uploaded directly to our servers. I will confirm when it comes in so you know that we have it.


Hi @wintoid ---- Touching base with you to let you know that the diagnostics report has been received and has been based over to our tech team for review.


1 Like

Thanks @eric looking forward to hearing whether you can fix it :slight_smile:

1 Like

Hi @wintoid ---- Thank you for your patience here!

I wanted to touch base with you because we are going to reach out to Metrum to see what we can do to get one of these devices in house for testing. In order for us to properly evaluate this behavior we will need to make it reproducible in our QA environments and having the gear in front of us will be the first step to that.

Again, your continued patience is very appreciated!

Hi @eric

Just for your reference, the Metrum connected via USB shows up as a Hiface device. I don’t know if the behaviour would be reproducible with just a hiface.



1 Like

FYI @support I am still experiencing this problem.

I pretty much stopped using the upstairs system because this was so annoying. It doesn’t happen with my other DAC. I am now at the point where I really want to use the upstairs system more, and I am re-experiencing all these frustrations. It’s spoiling the music for me.

What are my options?

  1. Replace the Pi with something else (SMS200? Microrendu? Aries Mini?) and continue using USB?
  2. Buy a hat for the Pi and switch to coax/optical?

Are any of these guaranteed to fix the problem? Or are Roon on it? Rather frustrated right now!



Or should I try Ropieee instead of Diet Pi?

Looks like Ropieee has fixed this for me! Result and instant donation of course!

I guess maybe DietPi had an older kernel?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.