'playback failed because $ couldn’t connect to HQPlayer '

This message apear after a power off/on of my sonicTransport and streamer. I use the 4 Embedded server software installed on the sonicTransporter on which Roon is also installed. Now I already know that I have to go to the configuration page and then enter my backend in Device at the bottom. What is the best way? On the image below you see the most common screen and I can’t do anything with that because the word Current makes that it doesn’t work.HQPl%20device%20fout
It works in the image below. There you can see that there is a choice without the word Current. If I choose that, the problem with Roon is solved. How do I ensure that the option of the bottom image appears?

Hi @Bert_Dijkstra,

Thanks for reaching out here. I am not too familiar how HQPlayer interacts with the SonicTransporter (and this issue is very likely outside the Roon domain) but some basic questions that may help get things going:

  • Is the SonicTransporter + DAC up to date on the latest firmware?
  • Does only rebooting the USB DAC get it to show up properly?
  • Have you tried a different USB cable to see if this has any change in behavior?
  • Have you tried re-installing HQPlayer on the SonicTransporter yet?

Also, similar behavior has been reported in the following thread, maybe this is the same behavior that @lkjhgdaa was experiencing?

– Noris

I’ll tag the Guru @jussi_laako to correct me if I’m wrong but I think this is normal - after a poweroff of the NAA (Rendu) you need to select the NAA backend next time you power on and hit ‘apply’

I got around this by just leaving the NAA powered on…

The issue I experienced (linked above) was very different but solved thanks to Jussi’s incredibly hard work. That was a fun time for him :upside_down_face:

What is the power and input status of the DAC connected to your mR when you see this ?

Generally speaking if you:

  • turn on the DAC and select the USB input before you start HQP; and

  • turn off HQP before turning off the DAC or changing inputs

then HQP is more likely to discover the mR immediately.

Thanks Andrew, but a bit hard to understand for me. Where do I select the USB input before I start HQP? I do understand the order in power off my devices. First the sonicTransport and second the streamer. Turn on the streamer (where select the USB input) and second turn on sonicTransport
I show a screenprint of the streamer with DAC, maybe it helps to understand.

On the DAC.

Hello Andrew,
It’s a streamer with a DAC within. I can only power on/off the streamer, nothing to select.

1 Like

If there’s a new item shown instead of “Current”, then name of the NAA has changed (seemingly not in this case) or the hardware device id within the Rendu. Or it just wasn’t available when HQPlayer server was started.

Hello Jussi,

What is the best solution to make it work again when the hardware device id within the Rendu has changed or if it just isn’t available when HQPlayer server is started. If I have to power off both units (during long vacation or after power outage) whats the best way to startup (start order) both units. Andrew did give an instruction a few posts above.
Till now, after power off, I got it working accidentally, without understanding what did the trick.

Thanks for answering, Bert.

While waiting for Jussi’s reply, try to power on your DAC first. Wait a minute till the internal Rendu and NAA has properly booted. Then power on your HQP server last.

From:

Hello respondents,
I am now on vacation for a month and a half. Before I left, I removed all my equipment from the power. I will be back in mid-July and hope to get the server and the streamer connected again without any problems. I will certainly place a report in this item.
Greetings, Bert.

1 Like

Hey,

What I was afraid of happened:
First I started the streamer with the NAA inside and after half an hour the sonic Transporter with Roon Core and HQPlayerd. I opened Roon on my computer and the streamer with HQPlayer could be seen in the bottom right. I also saw the last song I had stopped before the holiday, the line with frequencies and the red progress line was also visible. That looked good. I pressed play and there was not the annoying message (see title of this topic) but something else happened. The double bars of play were visible but the red progress line did not advance and there was no sound from the speakers. After checking whether all connections were correct, I didn’t see any blinking LED lights on the back of the sonicTransporter at the exit to the streamer. After I reconfirmed the LAN cable between the streamer and the transporter and I opened the HQPlayerd configuration program via manage sonictransport, I saw in the bottom right of Network Audi Backend Device that I was happy to choose from my device with and without the word Current, of course immediately selected my device without the word Current> Apply and … it worked exactly the way it should. Strangely enough, Roon did not display my second location. After I restarted the computer it was visible and worked as it should. Conclusion: it is still unclear why something suddenly does not work after a time of power failure.

Greetings, Bert.

Hi again Bert, I do this part (selecting the device without ‘current’ and hitting apply) each time my HQP Embedded server and my NAA are powered on.

It takes me under 15 seconds to do because you can just bookmark the HQPe ‘config’ page on your website browser favourites, for very quick access. And this only needs to be done once, each time everything is powered on.

Hi Sean,

Thanks for answering.
After my last power off I had another problem, probably the ethernet cable was not connected properly. And apparently after the restored connection the choice in the configuration program has changed. I could suddenly choose my streamer without the word current before it and everything does work properly. But now I still don’t know why one time there is nothing to choose and there is no solution and the other time that choice is there and then I choose my streamer without the word current then it works perfectly again. It seems that I can invoke the choice with and without current by breaking the connection between streamer and transporter and then reconnecting. I have not tried it again because I am happy that everything works and I am not in the mood for problems again. If a power failure is necessary at a given moment, I will certainly try it out.

Greetings, Bert.

Hi @Bert_Dijkstra

I noticed you are directly connecting your network DAC (with internal Rendu) to your sonicTransporter?

Do I understand this correctly?

This would mean the sonicTransporter’s 2 x ethernet ports are operating in bridge mode which SHOULD work but I wonder if you have the same issue if you connected both DAC and sonicTi7 to a separate, simple un-managed switch, like a Netgear GS105 or GS108?

Hello Sean,

Indeed, I connected the streamer directly to the Transporter because there are two ethernet ports. In this video on YouTube:


from Small Green Comp. you can see/hear why . It is really advertised as a better solution to prevent noise. It was an important reason for me to purchase this. No extra switch with a switching power supply. That is why I am not going back to an extra switch so that I can connect both devices separately.

Greetings, Bert.

Hi @Bert_Dijkstra

Yes I know about the two ports as I’ve had the same sonicTransporter :wink:

While it may have SQ benefits, I was just wondering if it was also the cause of your practical issues… there’s no way to know without testing with a separate and ‘dumb’ un-managed switch…

But if you’re happy with everything as is, then that’s all the matters.

Best regards, Sean.

Hello Sean,

Thats right: if you’re happy with everything as is, then that’s all the matters.
But if I have the same problem the next time I sure will try your suggestion.

Greetings, Bert.

1 Like