Playback failed on HQ Player after 1.6 update [Solved - HQPlayer reset settings]

@support, I can’t seem to get Roon to work with my NAA/HQ Player setup in version 1.6. It works great on my desktop in Wasapi mode, but when I connect to HQPlayer I get the following error message: “Playback failed because $ couldn’t connect to HQ Player.”

Any ideas on what’s wrong?

Hi @sdolezalek,

Thanks for contacting us regarding this issue. Can you please post a screenshot of the error you’re seeing? Also, have you tried rebooting your Core and networking gear and the same behavior is still occurring?


I fixed the problem. When I updated to 1.6 it seems to have reset the Audio App switch from HQPlayer being “Active” to Roon ready being “Active.” By going into the NAA and resetting that to HQPlayer it fixed the problem.

1 Like

Hi @sdolezalek,

Thanks for letting me know! I have marked your post as the solution to this issue in case other people are having the same issue.

– Noris

I’ve the same problem but I’m not sure how to implement sdolezalek’s solution…I’ve no NAA and both Roon and HQPlayer sit on my HTPC.
Could you please expand?
Thank you in advance!


Pietro: I have Roon Core and HQ Player on my HTPC, but located in my office. From there I run Ethernet to a Sonicorbiter (which functions as my Network Audio Appliance (NAA), and I run USB fom there to my DAC. Are you running your HTPC straight to your DAC through USB? Ethernet? Directly?

Because of my configuration, there is a sepoarate piece of Roon that sits on the NAA. That is the piece of software that reset itself to prioritize Roon over HQ Player.

Yes, HTPC straight to the Dac through USB.

When you go into the HQ Player “Settings” page, does it show your DAC as the output? I looked at the Roon Core settings and couldn’t find one that corresponded to the choice I was able to make on the NAA. But if HQ Player isn’t seeing your DAC in “Settings” that at least gives you a further path to explore.

A post was split to a new topic: HQPlayer not working after 1.6 update

Yes, HQPlayer sees my Dac and works perfectly on a stand alone basis.

The problem is related to the relationship between Roon and HQPlayer: when I try to play a song in Roon through HQPlayer (and to the Dac via Usb) I keep on getting the error: “ Playback failed because $ couldn’t connect to HQPlayer “.

This happens both in Win10 and Linux (Gentoo).
I have the last version installed (1.6 build 401), and HQPlayer is 3.25.3.

Hello @Pietro_Grassano,

Have you made sure to follow the HQPlayer setup instructions listed here?

– Noris

Thank you Noris, re-done and solved, thank you.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.