Playback is experiencing randomly stoppages

Hi @Daniel_Blount ---- Thank you for reaching out and my sincerest apologies for the delay on my end.

I wanted to reach out to see if you have taken the update to the latest build (i.e B354) and if you are still running into the random stoppages in playback?

The reason I ask is because as mentioned in my previous update our QA team was able to reproduce this behavior and fix has gone out with the latest build. So I am eager to hear what your experience has been like on B354.

Looking forward to your update!

epic indeed…

Hi @eric

Well, I’ve had everything updated to the latest for a few weeks now and I want to say things are a little better, in other words, less frequent stops. But, it still stops. For a little while it seemed to stop maybe once a day, but I was not sitting down to listen. So this AM, had a couple hours to listen to music and… stops, hit play again, plays a song or two and stops, repeat… just stopped again…

Logs are here

Hi @Daniel_Blount ---- Thank you for following up with me and sharing the observations you have made after updating to the latest Roon build (i.e B354). The feedback is a very appreciated and sorry to hear that the reported behavior is still occurring.

Continuing forward, I have made our techs aware of your report and have attached the latest round of RoonServer logs to your ticket. I have asked the team to review them to confirm if we are seeing the same traces we had been seeing previously before the fix went out so we can try to understand why this issue is still occurring. Once they have an update for me I will get in touch ASAP.


Thanks for looking at this so quickly.

To answer the questions:

1 - Yes - No change
2 - ROCK, NAS and endpoints are all individually Ethernet wired to the D-Link Switch
3 - The USG is my router. I do not have a router from the cable/phone company (Verizon). So their fiber network is converted to Ethernet in what they call a network terminal and that WAN signal is fed to my USG router.

Let me know if that answers it. THanks - Dan

Hi @Daniel_Blount ---- Thanks for getting in touch with me and providing the requested feedback. Appreciated!

I have been trying to do some research into the functionality of the Unifi USG because as mentioned I am not very familiar with the unit. My concern at this time is that the device itself may be having some issue with multicast and being as Roon relies on multicast to communicate with it’s endpoints this may be why you are experiencing some stoppages in playback. A few things…

  1. The next time a stoppage in playback occurs can you please open the Unifi controller app and check the “Devices window” to confirm that all endpoints are still listed and in an active state.

  2. I found this article regarding the USG + multicast. What I would like to see, if possible, are screenshots from the Unifi controller application regarding “settings” and “security” if they in fact exist. Just trying to determine if there are any settings that jump out at me as “red flags”.


Note: Being as the team is seeing something in log traces now that may indicate a possible environmental issue I have started a new thread.


Finally got some time to look at things:

1 - I’ll update if when a stoppage happens and see if the Lumin uptime has reset on the clients page.

2 - Here is the settings screenshot.

Here is the ‘events’ log, the end points seem to disconnect often, even though they are still playing:

Here is the network info:


Here is the screen shot when the Lumin stopped:

Not sure what this means other then the "LUMIN disconnected from “LAN” (7h 48m connected, 460 B) 8:20 pm 11/28/2018 " at about the same time the music stopped. Of course at "LUMIN disconnected from “LAN” (7h 13m connected, 184 B) 7:43 pm 11/28/2018 " it did as well and was still playing.

Hi @Daniel_Blount,

Thanks for providing the screenshot! I’m going to pass this along to the team for their review. I’ll be sure to update you once I’ve received their feedback.

Hi @Daniel_Blount,

I spoke with the team about this today and wanted to reach out with their feedback. When we first discussed this issue with you, we were seeing traces in the logs that pointed to an issue on our end. That has since been resolved and we have confirmed that you are no longer experiencing this issue based on the most recent diagnostics analysis.

The new playback stoppages appear to be stemming from networking related issues, which is supported by the last screenshot that you sent above. In the logs for your router, it shows that the Lumin device is disconnecting from the network. When this device disconnects, Roon can no longer communicate with the Lumin, which is why you’re experiencing this.

Once the Lumin disconnection issue is resolved, Roon should not have any issues communicating with the Lumin. I would start by enabling IGMP Snooping in your router settings and seeing if that yields any change. I would also reach out to UniFi and see if they can provide more details on why the Lumin is disconnecting.

If you notice any issues with Roon when the Lumin disconnection issue is resolved we will be happy to take an additional look. Just let me know if you have any questions!



Thanks Dylan. I am investigating it with Unifi and have enabled IGMP Snooping just now. Just to follow up, I have determined there is no time correlation between the Unifi log entries of LUMIN disconnecting and reconnecting, and the playback stopping. As an example it just stopped 3x in a 15 min span and the Unifi log has no LUMIN events. However, LUMIN (and my canon printer??) is the one that is connecting/reconnecting the most it seems, so something is going on.

Wanted to close (hopefully!!) the loop on this issue. After discussions on some other forums, and some additional tests where everything worked fine without Roon in the mix, I replaced my network switch with a CISCO SYSTEMS 24-Port Gigabit Switch (SG11224NA), and everything has been playing reliably without stopping for 48+ hrs now. Can’t say I really understand it, but I’m just happy it all works properly again (the whole reason I went with Lumin and Roon after having other more fiddly solutions)!

Thank you again for the support.

The reason is that your switch is faulty and/or unable to handle the amount of multicast traffic required. Recently another case also required replacing your brand of switch: Roon losing connection with ASUS AC5300 - [Solved - Faulty Switch & Modified Router Settings]

The reason I suggested to replace the switch is because of the post above, and I happen to have the same brand of switch under my desk, which is also unstable.

As for the suggested replacement switch, I have previously described it here:

@dylan Now that this is solved, would it be appropriate to turn off the unlist state of this thread, so the solution becomes searchable?