Playback issues with Primare SC15 Mk 2

Roon Server Machine

Intel NUC 10 i3, 250GB RAM, Roon ROCK build 259
Remote: Roon Version 2.0, build 1357 on iPhone 15 and Mac

Networking Gear & Setup Details

Eero Pro 6 mesh router with NUC connected by ethernet.

Connected Audio Devices

Primare Sc15 Mk2 connected to mesh by ethernet, with WISA connection to Buchardt A500 active speakers

Number of Tracks in Library

Library approx. 6000 tracks

Description of Issue

A few days ago I replaced a Platin Hub with the New Primare SC15 Mk2 as my Roon endpoint, using a WISA connection to Buchardt A500 active speakers. With the Platin Hub I had no problems streaming from Roon with either locally stored tracks or Qobuz and Tidal.

With the new Primare setup I am experiencing repeated glitches where the music abruptly stops after a random length of time. This happens with local tracks and streaming services. The Primare SC15MK2 appears in Roon audio settings as Roon Ready but uncertified and cannot be enabled, so I have set up Chromecast Streaming and Airplay through Roon until the SC15MK2 is certified. The playback problems are particularly acute using Chromecast streaming - when playback stops the icon next to the currently playing track continues to move as though playback is continuing, but the progress bar at the bottom stalls and the tracks stops.

I can Chromecast to the SC15MK2 with native streaming apps like Qobuz and there are no similar problems.

1 Like

Hi @Jeremy_Greenwood,

Thanks for taking the time to write in, and I’m sorry to hear you’re having playback issues!

Before anything else, are you able to reproduce this issue from a more simple playback option - like from a system output of one of your remote devices, and or mobile device?

Roon demands a bit more network-wise compared to other software, are you able to review your router settings and test out adding your server to have priority when in use?

Lastly, could you please reproduce the issue and share the specific date, time and name of the track playing when the issue occurs?

Once you let me know this info, I’ll go ahead and enable diagnostics for your account so I can review the logging for clues.

If you’d rather do it yourself manually, please use the directions found here and send over a set of logs to our File Uploader.

Thanks!

1 Like

Thanks @benjamin

On your first question - I’m not completely clear what you mean? I am using Roon remote app on my phone to control playback when the problem occurs if that’s what you are asking. Casting with other apps eg Qobuz from the phone seems to work fine.

I just reproduced the issue on Jan 12th at 3.57pm Mountain Time whilst playing the Wilco track Impossible Germany from Qobuz.

I’ll look into the other network questions as well.

Hi @Jeremy_Greenwood,

Thanks for the follow up!

Apologies for not being more clear - I am interested in seeing if the playback issues you experience happen completely outside of the Promare SC15. If you play audio from the local speaker on your MacBook air, or your iPhone, does the same issue occur?

From reviewing your server diagnostic report, I’m seeing fluctuations in network bandwidth prior to the dropout.

Is your Roon Server device hardwired to the main/primary router in your mesh network?

Thanks for getting back to me @benjamin. I will need to test playback on the phone and MacBook but won’t have a chance to do that until next week…

On the server question it is hardwired to a satellite Eero device rather than the main router. It’s the same Eero that the Primare SC15 mk2 is hardwired to. I can try moving it to the main router if necessary? Again I can’t do that until next week. My observation is that the dropouts occur using Chromecast streaming with the current configuration but not using Airplay streaming, would the chromecast option be more prone to issues with bandwidth fluctuations?

Hopefully the SC-15 mk2 is Roon certified quickly and that sorts out the stability problems!?

Hi @Jeremy_Greenwood,

Yes, I would test out setting things up (temporarily) to your main router. It may help clear up any network noise potentially blocking your chromecast connection.

Just wanted to chime in and say that I have the same exact issue as the OP described.

I also have the exact same issue here
Is there any fix available?
My SC15MK2 is now on 1.57 but still the same issue.

Have you checked the “flow-control” network option in your router/managed switch your roon endpoint is connected to? Try turning this option on for the port the endpoint is connected to. In my situation it was the core issue.
In general it’s always wise to connect roon (ready/tested) devices fully by wire to circumvent any potential issues coming from WiFi.

Here SC15 is connected over Ethernet.
I have other Google Cast devices in the house, all running Roon without issues.
I use the ISP router and don’t know how to check this.
Plus, as explained by OP, casting directly from another app runs ok, but via Roon it doesn’t

A non roon streaming app that works flawlessly in the similar or equal network a roon system is integrated in is by far no guarantee that roon will work fine with a certain endpoint. That’s unfortunately mainly the consequence of roon’s own protocol RAAT.
Do you have admin access and credentials for your router? How many LAN ports does it have? No other switches, just the mesh boxes?

Please correct me if I am wrong but no RAAT here:

Here, the ISP router has 5 Ethernet ports directly injected on the house Ethernet cables. I only have Roon Server, Nas, SC15MK2 and a Ropieee device wired over Ethernet. Other pieces of equipment use Wifi: tv , chromescasts, Google home, PCs and smartphones. I even tried to switch all Google devices off and the issue still happened. To me it looks like a software issue either on Roon or Primare side.

Yes, somehow strange. If you look through some of the more recent threads I found similar issues described with very different endpoints also using the integrated Chromecast. This lets me think there’s some issue with integrated Chromecast when controlled by a roon server. No idea if the core issue is with the roon software or the endpoints’ integrated Chromecast, though.

1 Like

Which equipment for example?

Read e.g. Lyngdorf may give dropouts using integrated Chromecast. Similar symptoms with external Chromecast attached to a NUC with ROCK.
BTW, are you able to reproduce the issue or success with different file types, kHz or bitrates?
roon says most devices’ integrated Chromecast is supported…

Hi Benjamin,
Here I have the same issue with SC15mk2, and I have several chromecast ultras and Google home devices. Only the SC15mk2 presentd the defect. Do you really think it is network related as 4 others (over wifi) don’t have problem?
When playing via Qobuz directly via Google cast on SC15mk2, no issue. Only using Roon causes the issue. Glad to have your point of view on that.
Kind Regards

Hi @Judelow,

Thanks for following up! We’d like to take a closer look into the chromecast communication within your Roon Server - could you please reboot your server twice, reproduce the issue and share the specific date, time, and track playing?

We’ll be able to enable a fresh diagnostic mode for review after the above. :pray:

Thanks
I just rebooted twice between 18:55 and 19:00 (Paris time) issue happened at 19:01 , track played was " The Ghetto" by Donny Hathaway and blocked at 0:44 sec.
Today is the 22nd of February

Issue also reproduced at 19:26 (+ or - 1 min) with the following track


Please note that the song is stoped but the display still present the “pause” option as if it does not noticed the song stopped

Thank you for the detailed report @Judelow, our team will review and follow up as soon as we can! :+1:

@benjamin
Hi Benjamin
Any good news?