Playback issues with the dCS Upsampler (Build 298)

Its back…same thing with 298…lock ups, playing with no audio. Resync dealys setting changes don’t help.

Restarted Upsampler, core, remotes…nothing changes…

Does it happen with ROCK too?

I have no idea about ROCK

1 Like

Thanks for the feedback @G997 after having updated to the most recent build. The insight is always appreciated!

Moving forward, I am going to have our tech team look into this behavior you are are reporting to see if we can figure out why you may still experiencing this issue. Once I get an update I will be sure to follow up promptly. Your patience is appreciated while we investigate.


Hi @G997 ----- I have went ahead and split your posts out to a new topic so we can address this report (in relation to the latest build) with you directly.

Moving forward, our tech team has asked if you would kindly please provide a brief but accurate description of your current setup using this link as a guide.


Hi Eric…My system is not for public visibility. I think Mike might have my setup…

Nothing has changed from last time. I upsample to DXD, also tried upsample to DSD and 192. Nothing helps. The biggest issue used to be going from any lower resolution track to a DSD track but now, with this build, going down in resolution also cause lockups I can add that changing resync times for the dCS Upsampler have no effect, the time to start playing a different resolution file stays the same…a significant delay. Track to track with same resolutions works.
Also, I have two cores to work with, one a W10 machine and the other a SGC sonicTransporter i7 Linux and both exhibit the same behavior…(each one inserted in system individually)

@G997 ----- Can you please provide me with the details of your setup in a PM so I can update my report for our tech team to evaluate. Many thanks!


Still holding off from updating to 298 because of this report. Any updates here?

I’d hold off…

Had to give it a try. Updated to 298 and everything works fine with my dCS Network Bridge. This is on ROCK by the way.

Anything happening to solve this???

Hi Support,
I would appreciate your help.
After doing the latest update to my roon core and roon ipad program, I have a very strange problem.
Important - When a playlist song ends it goes directly to the next song and starts play in about 1 second. (as normal)

But - when I click on the “next song” (arrow with line), it takes 14 seconds to start moving the timeline off zero and play the song. during the 14 second wait, the little blue meter on the left of the song is moving as if it is playing.

If I use my touch screen on the highlighted song and pick “play now” from the blue icons, it still takes 14 seconds.

Server is a properly set up and updated Windows 7 machine with SS hard drive. All ips are dhcp. Never a problem before.
Roon Core is 298,
Tablet Version is 294
ipad is newest 11.5.2

I rebooted all, checked firewall settings, changed my dhcps to static and back…
I use the dCS Network Bridge as my Roon endpoint. no new updates available there.

This is quite maddening.
Thanks for your help.

Hi @Joseph_Gerardi

I’ve merged everything into the original thread. Can you describe what kind of CPU you have in the Core machine and the topology and hardware of your network ?

Hi Andrew,
Thanks so much for your help.
For the Roon Core computer, I have an older Dell Precision T3500 with Dual Core Xeon CPU W3505 @2.53Ghz 2.53Ghz
8 GB of Ram and 64 Bit Windows 7 Professional
500GB SS drive.
(A bit old - but a strong computer)

Network is pretty straightforward with Xfinity Docsis 3 Modem\Router\Wireless (newest single box)
going to a good Gigabit switch, which feeds the Dell T3500 computer, my dCS Network Bridge, and my Synology NAS with music. (all wired ethernet)
A new, updated iPad with updated Roon remote is on the same network wirelessly.
All of them are Dhcp.

The Dell computer Roon Core plays the NAS music through the dCS Network Bridge

It usually runs very quick and very strong.
I started getting this weird lag a few days ago.
(and it is only on all manual input - playlists play normal unless you try to play one song out of order - then the delay happens. also if you grab the timeline and move it - the delay happens)

Thanks again,

My first suspicion is the switch as the problem seems to arise when your iPad (wireless connection to Router) tells the Core (wired connection to switch) what to do and doesn’t arise when the Core is telling itself to play Radio. Can you describe the make and model of the switch ?

Good troubleshooting practice is to simplify and see if that changes anything. Can you try connecting the Core directly to the Router by Ethernet and checking if the problem persists ?

I just used remote desktop to log into my core computer at home,
and I used the core directly to start playing music on the Network Bridge output.
Result - Even without the iPad in the loop, the core is experiencing the lag when I move the timeline or use the “next” button.

I do have one other gigabit switch before the Network Bridge.
I will swap out that switch this evening, just in case.

Yes, I will simplify it completely tonight when I get home and go from there.
(wires across the floor if need be)


Wow… I just eliminated the switches completely by wiring the Bridge, the computer, the NAS all directly to the Modem\Router.
I also reset the Modem.

Without any switches, and without any iPad, I still get the 14 second wait after I push the play button.
All the symptoms are the same. Even Tidal has the wait, so it cannot be a NAS\file issue.
So, It is not the iPad, not the switches, not the NAS.

Is my next step to delete Roon and start all over with a new install?
Try to find a System restore point a couple of weeks ago?

Your suggestions are welcomed.

Thanks Joseph,

All good troubleshooting. I’m going to leave it to @support now as I suspect they may benefit from looking at your logs.

I have the same issues with dCS Upsampler…as well as others. Its been days since 298 and nothing seems to be happening to solve things