Playback keeps stopping on ROCK Core

Core Machine (Operating system/System info/Roon build number)

ROCK Version 1.0 (build 175) on a NUC8i3BEH with 8gb DDR4, 256 gb PCIe SSD boot drive, and 240 sata ssd for storage

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ROCK connected via ethernet to an Airport Time Capsule 802.11ac (Version 7.9.1)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

chromecast audio; chromecast; iPhone. All are connected to the Airport Time Capsule via WiFi.

Description Of Issue

The Roon Core stops working every 10-40 minutes of playing. When it stops working, the music stops playing and the Core becomes unavailable on all devices (iPhone app; iPad app; MacBook app). The Roon App indicates that it cannot find the Core. If I click the option to select another core, the correct Core is listed as “initializing”. Within approximately 1 minute, I can connect to the core again and it functions properly until it crashes again (in the same fashion). When I check the Core’s status on WebUI, it does not indicate that the Core has rebooted. Rather, it indicates that the Core has continued running and is stable, even when the problem has occurred just a few minutes prior. In most cases, the Core starts working again without the need to reboot.

This issue is not specific to any of my devices. It has occurred on all of them, including the chomecast, the chromecast audio, a chromecast speaker group pairing the two, as well as the iPhone. I have also tried disabling and reenabling the devices, as well as restarting the router and all devices. It does not make any difference.

The vast majority of my usage is through Tidal. I have a very small local library, so I cannot confirm whether this issue occurs with my local library as well.

This problem has been occurring consistently since I created the Core a few days ago. When I created the Core, I imported my database from my MacBook. I had previously run Roon on my MacBook for approximately 1 week, and it worked flawlessly.

I also tried reinstalling Roon a second time. It did not make any difference. I have confirmed that my BIOS is up to date, and all BIOS settings are in accordance with the recommendations on the Roon install page.

I appreciate your help. Thanks.

Hi @James_Kutter,

When this issue occurs and your remotes are disconnected from your ROCK, is the WebUI still accessible?

Yes, the Core remains accessible on the WebUI. There is also no change to the display through the NUC’s hdmi. (It continues to indicate the same standard language regarding the Roon OS and Web UI IP address).

In case it helps, the error just occurred at approximately 12:45 PM Eastern Time.

Thanks for your help with this.

Hi @James_Kutter,

Thanks for confirming that additional info.

Yes, this does help. I just activated diagnostics mode for your ROCK and what this action does is automatically upload a log set to our servers for analysis.

I see here that your ROCK rebooted RoonServer at 12:45PM, which is likely why you saw the “Initializing” message on your Roon Remote.

I would try a few things here:

  1. Can you try connecting your ROCK to a different power outlet? I wonder if it is loosing power temporarily and starting back up again.

  2. I would try performing an OS Reinstall via the ROCK WebUI. Please be sure to create a Backup of your current database if you have added any new info.

Thank you for the additional thoughts.

With respect to the reboot: I should clarify that I had rebooted the machine just prior to experiencing the issue. I experienced the issue during the first song that I played back.

Also, as part of my troubleshooting of the issue in the last few days, I tried a clean reinstall of Roon using a usb flash drive. It did not fix it. I have also tried the “rock reinstall” option on the WebUI interface (on multiple occasions). It did not have any impact. Should I try it again?

With respect to the power outage, I will try a different outlet. However, I can confirm that during the events, the Rock continues to show a solid blue light and continues to display that it is running through the WebUI and the HDMI. The WebUI also reports that the Rock has continued running through the event. (For instance, if the Rock has been running for four hours prior to the issue, then after I experience the issue, it will indicate that the Rock has been running for 4 hours and 5 minutes).

Sounds like a hardware issue. See my post on mangled/stripped SATA cable. Even though that cable was just to my internal storage SSD, it brought the whole thing to a collapse, even streaming, despite still seeing the core on the web UI, and being able to reformat the SSD etc. Cable electrical taped back up and not a hitch since.

Charles, thank you for the suggestion. I opened up the NUC and confirmed that there was not any fraying. (It is a brand new NUC with all new hardware). I also reseated everything. Unfortunately, I still experienced the same issue within a few minutes after plugging the NUC back in. In a further attempt to rule it out, I also tried deleting my local files from the “internal storage” file and then removed the internal storage SSD completely (leaving only the boot SSD connected). I then tried to stream Tidal, and I experienced the same issue within about ten minutes.

Noris, I tried the “operating reinstall” again on the WebUI, as well as a different power outlet. It has not resolved the issue.

I also need to revise my answer as to whether the Core is available through the WebUI when it crashes. During the crash, I am not able to access the WebUI if I open a new web browser window and type in the IP address. However, I am still able to view the WebUI (and can successfully refresh the window) if I already have the WebUI open in my web browser.

Thank you again for your continued help with this.

Update: I began experiencing the same issue again this morning after approximately 45 minutes of listening.

The first time it recurred was around 7:00-7:05 AM Eastern Time. As usual, I was not able to connect to the core, and when I tried the “select another core” option, the core was listed as “initializing.” Also, when the issue occurred, I was still able to access the Roon on the WebUI by typing in the IP address in a new web browser. (Likewise, I was able to continue accessing the WebUI by hitting the “refresh” button in a window that was already open).

The issue also occurred again as soon as I got home. I started a song at around 5:45 PM eastern, and it stopped within the first 30 seconds of playing. I was again able to access the WebUI during the outage.

I would greatly appreciate any further assistance you can provide.


Hi @James_Kutter,

Sorry to hear that this issue is still ongoing even after reinstalling the OS.

I don’t see your ROCK communicating with our diagnostics servers recently, can I please request that you submit a manual copy of your ROCK logs by using these instructions? The best way to get them over to me would be via a shared Dorpbox / Google Drive / link.

Also, from what you have mentioned this issue could possibly be hardware related, I would run a check of your RAM to see if this is still intact using Memtestx86 if possible.


I am happy to report that I believe I have resolved the issue. I have not had any errors since the two that I reported above, at 7:00 AM and 5:45 PM on Thursday. It appears to have been a BIOS issue. I believe I resolved it by taking the following actions on Wednesday night: I loaded the BIOS screen, selected factory default, then reselected the settings per the ROCK installation instructions. After doing that, the issue only occurred two more times (the two instances at 7:00 am and 5:45 that I reported in my post above).

In case you still need it, here is a link for the logs.

Also, I ran the hardware test using Memtestx86. It did not find any issues. It did four passes and did not find any errors.

Thank you for helping me find a solution to this. I am very excited to have everything running well.


1 Like

Hi @James_Kutter,

Thanks for the update here, glad to hear that since reloading the BIOS settings that the system appears to be stable. If you experience any further issues do feel free to reach out again!


The issue has unfortunately started recurring again frequently. Every 5 to 45 minutes. It started again two days ago (the morning after my last post). I believe it coincided with an automated update to the OS – to build 183. At this point I am having the issue every 5 to 45 minutes.

Please see attached for updated logs. Could you please let me know your thoughts?


Hi @James_Kutter,

Noris is currently out of town for the next couple of days, but I’ll be able to help you out here while he’s gone.

Just to confirm, are the remotes still staying connected when the playback stops? You can still access the Web UI when this occurs?

Are you able to connect the MacBook to the network via Ethernet? If so, and you use the MacBook as your audio device instead of a WiFi connected endpoint, is there any change?

Thanks Dylan. I appreciate your help

The remotes are not staying connected. It says “lost connection! trying to reconnect”. Then if I select “select another core”, I see the ROCK listed, and it indicates that it is “initializing.” In most cases when this is occurring, I am still able to connect to the ROCK in the webui. (however, there have been a couple of times when I was not able to). The issue generally resolves in about a minute.

With respect to the MacBook, do you mean that I should try connect my MacBook via ethernet and use it as an endpoint, to see if the error occurs there as well?



I plugged in my MacBook via ethernet and turned off Wifi. I then set up my MacBook as an endpoint and played through the MacBook speakers. I experienced the same issue within about 10 minutes.


Thanks, @James_Kutter. This helps rule out potential networking issues.

Moving forward, I’d like to enable some further diagnostics on your account. Here’s what I’m hoping you can do:

  1. Start playback on the MacBook playing to System Output while it’s connected via Ethernet
  2. When you experience the issue, make a note of the time that it occurs and the track that was playing
  3. Respond here with that time and the track and we’ll enable diagnostics



As you suggested, I played the music through ethernet on my MacBook (using MacBook output/speakers). The error occurred between 7:45 and 7:50 PM eastern time. (My apologies – I intended to write down the exact time but do not have it). It happened while playing Jesus was a Capricorn (owed to John Prine) by Kris Krisifferson. It happened approximately :35 seconds into the song. As usual, the stopped playing, and the Roon Server was “unavailable” from the Roon app on my MacBook and iPad. After a couple of minutes, the Roon Server became available again and I could click Play and resume.


Thanks, @James_Kutter.

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Thank you. I played some music this afternoon, so the log should be uploaded at this point. Thanks again.

I purchased a new router today — a TP Link Archer C4000 — as I thought the problem could be my older airport router.

The new router did not make any difference. I am still experiencing the exact same issue. I am rarely able to play more than one or two songs before playback stops. I also tried adding the Roon and my playback devices as “priority” devices for the archer router. That did not make any difference either.

I appreciate any insight you can provide with respect to the diagnostics.