Playback Skipping

I have a problem with intermittent skipping during playback. Most skips jump to the end of the track. Sometimes it emits a noise for about a second before skipping forward. The behavior does not repeat in the same place if I replay the track, and usually doesn’t repeat at all.

My system consists of:
Roon 1.1, build 102, 32 bit.
Dell laptop with Intel i7-5500u processor.
Music files are CD resolution FLACs stored on a NAS, connected through a Powerline network adapter (not wireless).
Output is a Geek Out 450 USB DAC/headphone amp using the Light Harmonic ASIO driver. The audio option for Speakers/LH Labs Geek Out is disabled.
I’ve turned off virus checking during playback, but it doesn’t help.

Please help me troubleshoot.


You probably have checked but I have to ask. Are you using the latest windows 3.26 Light Harmonic driver?

Thanks. I was on 2.29. Just upgraded after reading your post. I’ll see if it helps. BTW, I’m still on Win 8.1.

It’s still skipping after the driver update.

Have you tried to restart Roon/DAC/Your machine after updating the drivers?

Yes. Still skips.

Would you mind to make a screenshot of audio settings (accessible from the small gear on the Audio tab of Settings) ?
Can you also try to playback the content which is located on the built-in storage, to exclude the network factor?

No skipping today, either from the NAS or from the local drive. Frustrating, because I don’t think I changed anything.

Here are the screen shots.


If it will re-appear again, try to playback local content first to exclude the network from our troubleshooting procedure.


I’m still having trouble getting the skipping to repeat. The day I wrote the original post was probably the very worst. Since, it has skipped occasionally. But after I heard a skip, it didn’t skip again, either in the original configuration (NAS + Geek), or in other setups (local disk + Geek, or NAS + headphone jack). So there are no new clues there.

Today, though it did something (only once) that I haven’t seen for many months. The player just stopped at the beginning of a new track. It required several clicks on the play icon to get it going again. During that sequence of clicks, the “signal chain: lossless” white spot disappeared. It reappeared just before it resumed playing. The input was the NAS and the output was the Geek Out Dac. Any suggestions?


The skips have been pretty rare lately, so I cannot come to a definite conclusion. But I’ve never heard a skip for music on the local drive. So let’s assume that the problem is in the NAS or network.

Any suggestions on how to proceed? Does Roon keep a log of failed file reads?

The network has been pretty reliable with video. The NAS is pretty slow, though files copy much quicker than the time required to play the music within them. Are there common configuration issues for either that I should know about?

Would a trial subscription to Tidal help resolve the issue by eliminating the NAS from the system?

  • SK


A real clue today. Finally.

It played well for about half an hour. Then the sound started to gurgle. You know the sound- Miles Davis sounded like he needed to empty his spit valve. The gurgles are not on the FLAC, and they are not on the original CD. I quickly switched to the music on the local drive. The gurgles did NOT go away.

Assuming there is only one root problem, this proves that the NAS and network are innocent. The problem is in the computer or in the DAC. After about 30 minutes of gurgles, my system was back to good sound.

Please suggest the next steps.

  • SK

Hey @Esskay, apologies for not responding you in time.

OK so let’s try the next thing:

  • Open Settings of your ASIO zone and mark ‘Use Max Hardware Buffer size’ - try to playback with such settings and see if anything changes

In case the situation won’t change I would like you to try the WASAPI zone. Steps you need to do:

  1. Disable your ASIO zone
  2. Enable WASAPI zone
  3. Turn on the Exclusive mode
  4. Try to playback using this zone

How about other players, can you reproduce this issue with FooBar or JRiver or any other bit perfect player ? ( Make sure that you are using ASIO driver with these apps).

Thank you in advance.

A post was split to a new topic: Playback pops and stopping - Windows 10


I haven’t had time to install FooBar to compare. That’s next.

But I have tried both WASAPI and the computer’s headphone output (bypassing the Geek DAC completely). Both had the same serious problems as using ASIO. Playing music from the NAS or from the local drive didn’t seem to make a difference.

Could other computer processes interfere with Roon? I did check the Task Manager. Roon uses only 240- 300 MB of RAM, always much more than any other program. But the Task Manager shows 35- 50% of my system’s 6 GB as in use. Sometimes the drive usage is more than 70%, though it’s mostly very low.

  • SK


FooBar/WASAPI seems to be OK. Because the problems are intermittent, there’s no guarantee that it will stay that way. Roon seems to play well for about 10 minutes after booting up. Then the problems begin. Again, that may be a coincidence.


Hello @Esskay,

Basing on your answers I can assume that:

  • this is not a network related issue ( this is happening to the local files also)
  • this is not an audio related problem (you have problems with any audio device)
  • this is not file related problem (you can’t reliable reproduce the issue with the same tracks)

So, it looks like interferes caused by other apps or hardware problems (bad drivers maybe) are the only things that left. At this point I’d like to look at your logs to ensure that your database isn’t corrupted and you aren’t experiencing buffering problems (more details in PM).

As for another tests:

  • Try to disable any software which can heavily interact with your hard-drive, for e.g.: antivirus(real-time protection), backup (scheduled automatic backups), torrent clients - and try running Roon without them.
  • Check power options on Windows - try to use High Performance Plan.

Can you also give us a better description of your machine’s specs (RAM, type of the drive its capacity etc.)?
How big is your music collection in thousands of tracks?

Thank you in advance.

1 Like


I will try turning off a few processes and changing to the high performance power plan. I am not running an auto backup program on this computer, but I do see some active processes from a Dell backup program that I haven’t activated. I’ve already tried turning off Norton anti-virus to no effect.

The computer is a Dell laptop running 64-bit Win 8.1 on an Intel Core i7-5500u with 6GB of RAM.
The built-in hard drive has 862 GB free out of 922 GB total.
The music resides on a QNAP TS-212P with a 3TB drive. The drive is about half full. The drive is mostly used for the music library and for a Time Machine backup for my Macbook that is not part of the music system.
There are about 18,500 tracks in the music library.



No help here. I’ve changed the power setting. Turned off as much of Norton as I could without uninstalling. Turned off TrueColor. Muted the system sound. Nothing helped.


Hey @Esskay,

Thanks for the feedback, your logs are still being analyzed. They contain some proves of the faulty behavior but only during playback of the content from your NAS. Can you please try to reproduce the issue with local content (located on built-in HDD) and send us new set of logs ?

Thanks in advance.