Playback Speed incorrect when changing sample rates

Roon Core Machine

MacOS 13.2.1, 2 x 2.8 GHz Quad-Core Intel Xeon, 16 GB 800 MHz DDR2 FB-DIMM

Networking Gear & Setup Details

Not relevant

Connected Audio Devices

Topping D10 Balanced, SPDIF to Genelec 8510A

Number of Tracks in Library

41,000

Description of Issue

When changing tracks with different sample rates, the speed of playback is incorrect. The DAC shows the correct sample rate, but speed is totally wrong.

Hi @Antony_Bernardo,

When you say “speed” do you mean the track is playing too fast/too slow?

The Topping D10 controls the SPDIF flow, have you tried power cycling it?

If that’s does not help reboot all equipment, and if it’s still an issue, post a screenshot of Roon’s signal path, and what your DAC is displaying.

Yes, I mean the track plays too fast/slow.

The DAC is showing that the sample rate has changed correctly and no other software has this issue.

Example: I’m playing a file at 44.1, DAC shows 44.1. I then play a track at 192, DAC shows 192 but the track plays WAY too fast. I think in this case if the DAC was incorrectly handling the sample rate, the file would actually play too slowly.

Which Genelec are you using?

Genelec 8351

(I put the wrong mode number in the original message - I can never remember it)

Are you running GLM software?
Does that tell you what sample rate the Genelecs are actually receiving?
You have the S/PDIF out from the topping connected to the AES/EBU XLR of the Genelecs?

(Trying to understand your config - I have a pair of 8020b so have none of these issues… :wink:)

I am using GLM, it doesn’t tell me the sample rate, but I can see the power indicator blink as it changes rates.

I’ve just tested with two other software programs that use Exclusive Mode (Izotope RX 10 and Foobar2000 for Mac), and neither of those have this problem (they also don’t take as long to switch rates).

I’ve also noticed that when switching rates, all my hardware devices go missing from Roon’s audio settings.

This problem is unique to Roon.

Peculiar. I have no idea at present but, in case it leads to a eureka moment, a few question come to mind…

Do the devices reappear spontaneously, or do you have to restart things?
Are you testing using exactly the same files with Roon and ‘other’?

Could you post screenshots of the Roon signal path when playing correctly, and playing incorrectly?
Screenshots of the config screen for the Topping in Roon?

I guess it could be a Mac interaction - do you have a windows box you could try as a Roon endpoint and plug the Topping into that?

Some further thoughts, which don’t actually fix the problem but work around it…

You could feed the analogue output of the Topping to the Genelecs. Not something I would normally suggest, but I’ve seen at least one report where the user claims to prefer this configuration.

Configure Roon to always resample to a fixed sample rate and bit depth, so neither the Topping nor the Genelecs need to switch. My understanding is that the Genelecs resample internally anyway, to 96/24 for the tweeter, and 48/24 for midrange and bass, so 96/24 might be the optimum setting. This might be the best configuration anyway - let Roon do any necessary resample so that neither Topping nor Genelec need to.

1 Like

Hey @Antony_Bernardo,

Ben with the support team here, I wanted to check in on this thread to see if you were still running into issues? And, if @AndyR’s note above was helpful at all?

If you’re still having this issue, please recreate it and share a time stamp of when the issue occurred. We’ll be able to take a closer look with this information. :+1:

Hi Gents,

Andy’s suggestion of resampling resolved the bulk of the issue. In hindsight, I think there’s probably some kind of poor implimentation in the DAC - it’s likely not Roons fault.

Anyway, thanks for all your help, I’ve found this forum quite useful :slight_smile:

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.