Playing 5.1 Multichannel Music on a Marantz SR7007

Hello, new to Roon and am having some difficulty getting my Marantz to play 5.1 multichannel files via Roon.

My setup includes an Intel NUC running Roon with an external SSD drive connected to the NUC via USB. The NUC is connected via HDMI to the Media Player HDMI input on my Marantz SR7007. Both the Roon and the Marantz are connected to my home network via ethernet and I’m able to play 2 channel music via airplay. I attempted to follow the audio set up guidelines I found but can’t seem to locate anything that will allow me to make the appropriate changes.
The following is what I see when accessing the audio setup:

and the resulting signal path:

I would think the direct HDMI connection from the NUC to the Marantz would provide the multichannel signal but am unsure what I’m doing wrong. Can anyone help this newbie out?

Your signal path shows AirPlay. You actually need to use HDMI. Do you see your Marantz under “Connected to Roon Server” in audio setup?

1 Like

Hi Ron,
I successfully operate a similar setup with no problems.
On my NUC running ROCK OS Roon reports several HDMI outputs. I remember trying them out to find the one doing multichannel.

hope this helps

1 Like

You don’t have the HDMi connection set as the zone in that picture your using Airplay. Have you enabled it in Settings/Audio it’s normally the first HDMI and should show the Marantz as connected. You need to enable this then select it from the Zone picker and play to it.

Thanks for your responses. I went through each HDMI connection in Roon and still no luck.

Here’s What my options look like under Settings → Audio

I’m connected under Media HDMI 5 to the Roon ROCK.

Under Device Setup I have the following options selected

And the following options selected under Advanced Options

When I select Media Player on my Marantz, I see that I’m connected to the Roon ROCK as it provides information on the Roon ROCK (e.g. model, operating system etc.). I do notice that it occassionaly transitions to a white snowy/static noise screen but no sound.

Clicking on the settings also notes that the volume control is “fixed”.

Looking at the Signal Path information, I can confirm that it is set to the HDMI and not Airplay.

image

Not sure what I’m doing wrong but any additional guidance is greatly appreciated.

HDMI 0 is the normal one that should be used I believe. Have you tried that one? Video out will just be the rock boot terminal screen if it’s locking properly. What model of nuc are you using? What OS you using and is HDA HDMI audio enabled in the bios and if using windows or Linux the driver installed for it?

Hi and thank you. I’m using a NUC Intel NUC 11 NUC11PAHi7 with Roon OS 1 (build 259). Not sure if it is HDA HDMI enabled in in the bios or how to check that. I just tried HDMI0 and am getting jittery sound out of all my speakers so that does appear to be progress but it is totally unlistenable.

Google shows lots of issues with this model and HDMi Audio but not many solutions. It’s a bit hit and miss is they work or not. I think you may need to update firmware/bios but may need windows to do so?

Also check for some BIOS settings. Some NUCs offer a BIOS option called “audio via HDMI” or similar. This must be enabled. Yes, according to roon, always select HDMI 0 from ROCK/HDMI.
indeed, ROCK NUCs are somewhat picky when it comes to mch output via HDMI. In case you use a managed router or switch, also check for “flow control”. Should be enabled for the ROCK port. But not so important if you run a complete roon server on the NUC.
BTW, some NUCs are said to be not mch roon capable at all. And always keep in mind, when talking about mch with roon it’s always about DSD or/and PCM. Roon does not support DTS or any other mch audio codec you may know from movies, BRs etc.

Thanks for the responses. I’ll do some more investigating into the BIOS set up this weekend. I find it odd that I’m able to get some garbled or jittery sound if I attempt to play 2 ch or 4 ch music via the HDMI. I also have another HDMI cable and will try substituting that cable to rule out a cable issue.

Hello. I just wanted to report back that the NUC BIOS was current and after replacing the HDMI cable I now have multichannel playback! I wanted to thank you all for your help and suggestions while I diagnosed this issue and wish you all a happy holiday!

Thank you Roon community!

2 Likes