Playing to Focal Arche just skips all tracks

Core Machine (Operating system/System info/Roon build number)

Mac Mini with Roon Version 1.7 (build 667) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Mac Mini is wired, Roon endpoint is wireless

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Raspberry Pi with Ropieee endpoint -> USB cable -> Focal Arche

Description Of Issue

I recently acquired a Focal Arche to use for headphone listening. When I try to play to this device all tracks are just skipped. Swapping the Focal Arche for another DAC leaving everything else in the chain the same works just fine. I am able to setup a zone with the Raspberry Pi and the Focal Arche (Roon says “FOCAL ARCHE Audio 2.0”. Is there an inherent problem playing to Focal Arche over USB?

Thanks

Hi Foxmoon,

You might try a test by removing the Pi and running the Focal straight from the USB out of the MAC Mini

I did just now again. It plays from my iMac using Decibel as a player connected through USB.

(to be clear, the Mac Mini running Roon Core is in a different location, I tested a direct USB connection to my iMac running the Decibel app completely outside of anything Roon)

Well, a good data point, but, not what I actually suggested. Did you try to play to the Focul using Roon while the Focal was connected to the iMac?

My was to connect the Focal to the Roon Core which is the Mac Mini, based on your description, and playing to the Focal using Roon.

Yes sorry I replied too quickly, see my edit above.

I can try your suggestion playing through Roon from my iMac instead of Decibel as soon as I can use Roon again on my iMac :slight_smile: The Roon client is currently crashing after showing the splash screen… (Roon Client crashes on my iMac)

You mention that the Rasp Pi is wireless, can you plug it up to ethernet and see if that makes a difference in playback?

Thanks, just tried that. Had to reconfigure Ropieee and reboot the Pi. Same result however, Roon just skipping through the tracks.

Hi @foxmoon,

I responded in your other thread regarding the iMac Crash.

If you try to connect the Focal directly to the Core and try to use Roon, do you see the same issue there?

Hi Noris,

I have connected the Arche directly to the Mac Mini running Roon Core and can confirm it works (no skipping and music is playing).

Then when I connect everything up again via the Raspberry Pi running Ropieee I get the skipping again. Problem must be with Ropieee, maybe you can move this thread over to the Ropieee category?.

Thanks

1 Like

Didn’t realize I can change the category myself. Moved to Ropieee now.

1 Like

@spockfish Would you mind having a look at this thread? Anything I can do to help debug the RoPieee installation?

Thanks for confirming that the issue is just with the Ropieee, you may want to try to re-flash the OS image, if that doesn’t help yes, see if Harry (spockfish) can take a look.

Hi @foxmoon

Can you send me feedback? You can find that option on the ‘advanced’ tab of the web interface.

So please play a few tracks and then send me feedback.

Thanks

Thanks for the reply. I have just sent the feedback through the web interface. The identifier is f12548ddbf2a8a58. Alvast bedankt!

Goedenavond @foxmoon,

The device is not behaving properly on the USB bus. The logs are flooded with USB error messages.

A few things you can do: make sure you have the latest firmware from Focal in the device.
If that does not work you could try the beta channel of RoPieee, which holds a newer kernel. I’m not very hopeful here, as this looks like another device that is not behaving properly as a USB UAC (USB Audio Control) device.

Oh. One more note: could it be that you run more RoPieee units? In that case I advise you to give them a different hostname.

Thanks

1 Like

Thanks for the quick reply. I do have 2 RoPieee’s they are called ropieee-1 and ropieee-2 (very creative, I know :slight_smile:)

I will contact Focal about any firmware updates and will try the beta release of RoPieee.

Ah ok. That explains the -1 and -2 :wink: But that’s ok.

Let me know how it goes!

Finally, I’m able to give an update. In summary it is working!

First I did was try a beta release of Ropieee from a couple of weeks ago. I couldnt get that to boot up at all, so I moved on to update the firmware of the Arche. It took a couple of weeks to track down the firmware via Focal and the local importer and also the upgrade was different from what was written in the Arche manual. I had to find a Windows PC too as the upgrade can only be done from Windows.

So after installing the firmware finally today, I also had to re-flash my Ropieee as the beta didn’t work. Turns out a new stable version was released on December 5 and I used that.

I can confirm the combination of the new firmware and the new Ropieee release works and I can now play from Roon to the Arche. Unfortunately I don’t know if it was actually the firmware upgrade or the new Ropieee version that did the trick.

Thanks to all who have responded to this thread!

2 Likes