Playlists GUI issue in Playlist track view

Core Machine (Operating system/System info/Roon build number)

iMac (Retina 5K 27 inch 2019

3GHz 6 core intel core i5

Memory 32Gb

Catalina 10.15.5

Hybrid Drive


MacBook Air
1.7GHz Dual core intel core i7
Memory 8Gb

Catalina 10.15.5


Also Docker Toolbox and Container running on above iMac - 8gb and the same 6 core i7 processor

Also VirtualBox and a VM running Debian 10.4 and Roon Core latest version

Synology DS216Play

Running DSM 6.2.3

4TB HDD Raid 1

Total tracks currently 12275

Roon 1.7 Build 555 with latest updates applied
Preferred install is with iMac running RoonServer and Roon as Control so that Roon is always running whether or not Roon control is running. Also use iPad and iPhone apps.
However have also tried installing just Roon as control, core and output and this makes no difference to the issue.

Lifetime licence

Also have a Qobuz Sublime+ account

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

BT SMart Hub 2
Netgear 24 port gigabyte switch
BT Whole Home Mesh and ethernet (NAS)
Have tried iMac both ethernet and wireless

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

System Output plus Auralic Aries and Auralic Altair G1.
iPhone and iPad
N.B. this issue applies whatever output device is used.

Description Of Issue
2 parts
IF using the LIGHT theme (the traditional one) and viewing playlist which has Qobuz content the Play Now Button is a paler blue and cannot be clicked. Ditto the drop down button adjacent.

IF using the DARK theme (the newer one) and viewing playlist which has Qobuz content the Play Now Button is a darker blue and cannot be clicked. Ditto the drop down button adjacent.

In either case I can select a track by clicking and holding and getting the options or right click and get the options above the default Play Now button.

However if the playlist is assembled from music in my own local library then all works as expected.

You mention build 555. The latest version is 571, you might want to check what versions your core and remotes are in and make sure that they are all the same.

Sorry my bad
I copied forward my set up details from a previous post and forgot to update
It is build 571

Hello @Marcus_Russell, and thanks for your report! I tried to reproduce this, but was unable to. Could you please reinstall Roon and test this again? Does switching zones help when you get in this state?

Hi @nuwriy

I have tried this on various installations and reinstallation’s due to an issue I was having with continuous track skipping (Roon Skipping Tracks and Playlist issue)
iMac both a Roon install and with separate Roon Server
I have tried it with a separate Roon server on MacBook
And I have tried it on Linux Debian (on a VM
And Docker container
All exhibit this issue and it makes no difference what the zone is.
And it persists across different control points (i.e. Mac desktop, iPhone etc.)

Hi @nuwriy
I have reproduced this error with Roon Server running on the iMac but I am now trying to reproduce this on Linux. I think I should have stated that it appears to be ok after a restart of Roon Server but comes in after a few hours.
Let me continue to test on Linux and I will report back if I still see the issue there with anymore details I can give

1 Like

Hi @nuwriy

I have no reproduced this on linux (N.B. this is a VM running new VirtualBox)

After restarting the iMac host Roon loaded but with ‘error loading page’
I went to load a playlist and found that the links at the top aren’t working.
I have taken a copy of the log files in case you need them - however as you have enabled debugging on my account maybe this is visible to your team anyway?

that should have been now

I have also restarted my host machine and the VM several times and the Playlists GUI issue in Playlist track view is now present all the time - i.e. at no point can I use the playlist play button or the drop down icon to its RHS

Hello @Marcus_Russell, and thanks for testing that! Could you please upload a copy of the log here? Thanks! Let me know when you’ve had a chance to do this and I’ll get it over to our team.

Hi @nuwriy
Uploaded just now as requested

Hi @nuwriy

This problem is still occurring but I have noticed what seems to be a temporary fix.

As I said this affects playlists with Qobuz content. If I am having the issue restarting the server has no impact but sometimes the issue seems to go away by itself.

Recently it was just exhibiting this post’s behaviour all the time and nothing seemed to sort it. So I tried disabling and re-enabling Qobuz in settings. This seems to fix it.
N.B. As I said above even with the issue I can still play the playlist by selecting the track and selecting ‘play from here’ but it is still annoying.
It seems like the code behind the button somehow doesn’t see Qobuz as connected or signed on or something.

Hi @Marcus_Russell,

I checked with the team and it looks like there were some networking errors showing in the logs you shared. We’ve found that Google DNS or Cloudflare DNS can often help with this. Can you give that a try and let us know if there is any change?

Hi @Dylan

I have added Cloudflare as primary DNS and will keep you posted. Initially after these changes I had to disable and re-enable Qobuz to get the play button to work.

1 Like

Hi @Dylan

Sorry for the delay in updating.
This issue still exists despite the DNS server changes.
Again I would affirm that disabling Qobuz and then re-enabling Qobuz sorts the issue until it recurs

Hello @Marcus_Russell, are you seeing this to multiple endpoints? How about system output of your mac?

Hi @dylan

If it happens it affects all end points including system output

Hi @Dylan
I should also have mentioned that if I disable Qobuz and re-enable Qobuz then that fixes it for all end points too

Hello @Marcus_Russell, since you’re also seeing this issue when playing to system output, could you please try disconnecting the core from your network and connecting temporarily to a mobile hotspot or another network?

Hi @nuwriy

I don’t quite follow

I think when I said system output I was referring to my iMac not the Rock core.
As the Rock core is on a virtual which relies on a bridge network I can’t see a way for this to work

In any event I have no other network issues so I think that for some reason Roon is polling Qobuz for this function, maybe getting no connection or more likely invalid login and then never recovers the log in
No other issues seem network connectivity related.

Hello @Marcus_Russell, my apologies for the confusion here. Since its a VM I’d recommend you switch temporarily to a different core and see if the same issue persists. Our next best move is to see if this is specific to your core or something happening on the network. Let me know!