Playlists not appearing after transferring Apple Music file to Roon Nucleus One (ref#11PO18)

What’s happening?

· Something else

How can we help?

· None of the above

Other options

· Other

Describe the issue

Playlist do not appear after transferring my Apple Music file from a Mac to a new Nucleus One. (Prior to this I was using my Mac as a Roon Server and the playlist were all there!) All my music transfers 100% into roon, with the exception of no playlist appearing. I followed all instructions: prior to transfer I made sure there was a Library.xml present in the music file/media file, checked box to allow Apple Music files to be detected, and the side bar library/playlist is on. Computer is a MacStudio running Sonoma. Again, when previously using my Mac with the roon software, playlist imported without a problem, not until I tried to transfer my music file to the roon nucleus one.

Describe your network setup

Spectrum cable modem, netgear orbi router, MacStudio computer running Sonoma

HI @darelflightrn,

Thank you for your post. Diagnostics indicate that the RoonServer on the Mac Studio remains active. The first step would be to complete the migration to the Nucleus by:

  1. verifying a recent Backup is available
  2. closing RoonServer, which is still running in the background on the Mac
  3. deleting the Roon database off of the Mac machine or changing the name so that Roon opens only as a Remote. Navigate to your RoonServer’s Database Location, find the folder that says “RoonServer," and rename the “RoonServer” folder to “RoonServer_old”

Once two databases aren’t trying to read the same music storage location, then follow the steps to import the .XML file again. We’ll activate logging in the meantime in case we need further follow up from there.

Hi.

I basically started from scratch, as I think creating multiple folders will only create more problems later.

  1. I reformatted the Nucleus One using the web application.
  2. Deleted “all” extra folders, so there is now only one active folder being the nucleus and not the Mac
  3. I then shut down the Roon Server software.
  4. I copied the iTunes music file in its entirety to the Roon Folder
  5. The “import iTunes playlist” turned during the import.
  6. Sidebar playlist activated and appears on the left side
  7. Verified XML files are in the correct locations in the music file and they are. (Apple playlist are present on my Mac)
  8. I restarted the Roon Server software, and the roon software appropriately read all the files and music, but again “no” playlist appear.

I’ll be honest here, this is much more complicated than it should be. Roon, was supposed to simplify things. Lack of phone support like “BlueSound”, makes me want to go back to that format. BlueSound would even take the time and screen share with you to resolve problems, here its a forum.

No Happy Sadly

Well, it’s now been 10 days since I’ve owned my Roon Nucleus One. I have spent nearly 1-2 hours each day trying to resolve why my Apple Music playlist are not being imported/displayed after importing in its entirety the “Apple Music” file onto the Roon HardDrive. The file contains a media folder with appropriate XML files for the music library and playlist.

Despite having read the instructions very carefully provided on the Roon website, multiple different attempts to get the Apple Music file into Roon (dragging it into roon app to copy, backing up file and copying it onto a USB and plugging into the roon, transferring the file using the I.P address of the Roon Nucleus…and even simply leaving my music file on my MAC and using it as a server.

It was mentioned to me as one explanation that why roon was not reading my playlist files, is that it was reading two files simultaneously (one on the MAC/one one Roon Nucleus One), despite correcting this problem, still no playlist

Here is the bottom line, despite whatever method I use, the files always copy/transfer with ease and without problems (give credit to roon), but the playlist are “never” transferred with the file and do not appear in roon.

This is both time consuming and very frustrating. I cannot envision how the “average” user who is new to roon would feel,

I purchased the Roon Nucleus One to be my music server. Prior to this I used my MAC as the server with no problems, playlist appeared. I am beginning to wonder if I should simply continue to do this, and simply get rid of the Nucleus One.

Sorry, simply very frustrated, running out of options.

DW

Clarification:

Here is the bottom line, despite whatever method I use, the files always copy/transfer with ease and without problems (give credit to roon), but the playlist are “never” transferred with the file and do not appear in roon.

The playlist do transfer, I can see them in the transferred files, simply the playlist do not appear the roon app after completing the transfer.

To me, this seems more like a roon “software” issue and not so much a hardware issue.

Thank You