Please help me play music through my streaming devices

  1. Christ, I don’t even know if roon is linked to my new tidal account??? I don’t understand this yet.

  2. I’m really just trying to play my music from either roon or tidal on my system in my room, my core should be my pc, has everything downloaded on it now - both tidal and roon, and my stereo is connected with a yamaha wxc-50 streaming device. I can play through my itunes easily enough but it’s not playing when I select my room under the roon app on either my iphone or pc. Please help me

Someone from the support team should be along soon, but I’ve just been looking at the specs of the WXC-50, and notice that it has Airplay support. That’s going to be the only way of talking to it with Roon (Roon doesn’t support DLNA)

In Roon (go to the Settings/Audio section), does the WXC-50 show up as an Airplay device? And have you enabled it?

You do not need Tidal downloaded on the same machine. It makes no difference to the functioning of Roon. You need to sign into Tidal through the Roon setup process. What have you actually managed to do?

Hi @jason_nales,

Starting out, there are a couple of articles in our Knowledge Base I’d like to point you to:

Setting Up TIDAL

To verify that TIDAL is properly set up in Roon, head on over to Settings | Services, as seen below:

Here you can verify that you’re signed in and, if you aren’t, enter your credentials to get your account linked.

Setup Audio Device

Next, we’ll want to make sure that your audio device is properly set up in Roon. To do this, navigate over to Settings | Audio as seen below:

As Geoff mentioned above, this device supports Airplay, so you’ll see an Airplay section like this:


If you see your device here, click Enable and it will be a selectable Zone in Roon. If you’re not seeing this device let us know and we can provide some further steps.

Playing TIDAL Content To Your Zone

After your Zone is enabled, you can select it from the Zone picker. Click the speaker icon in the lower right:

This will open up the Zone picker and let you choose the Airplay Zone that you enabled.

Now all that’s left is to navigate to the content you want to listen to, start playback, and it’ll play to this Zone.

If you have any questions about any of this please let us know!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.