Please make it NOT skip songs when "audio file is loading slowly" error occurs

Mhh , nope
You wait indefinitely for sure, but recover anything !
Skip to the next file on queue or exit are the best viable options
Also retry stream same file is a solution ,
for a number of times (how much? ) , but not the best logic if they give an error first …

Or at least a way to turn on logging for what gets skipped so it is easier to do root cause analysis


As a song skips with 60k tunes it very needed


skipped play with the loading slowly error ,latter is the cause …
skipped play , because the file/stream is unavailable , latter is the cause
skipped play , because the codec is unavailable , latter is the cause

root cause is not easy to solve because ,in most cases, is a correlation of multiple events. the root of these events maybe include issues on multiple “layers” not gathered by the software on top of these…


It doesn’t matter what the root cause is. The behavior of skipping the track when there is a problem is what drives me crazy.


Ok Mike ,

stop or pause reproduction (next track ready) are both viable options just like skipping , recover or retry are not feasible…

In simple words I often have 4-5 version of same song in many cases so would like a log of which song skipped to investigate file. Needs to contain song name and location only, time would be helpful for checking other logs.

Enrico you are making statements like you are on Roon team. If you are please identify yourself, otherwise comments are making me wonder how you make statements that you may or may not have knowledge of beyond an educated guess.

I’m an user , statements simply follow the logic of the protocol standards roon use for “streaming” . just like a web page, if the “load” fail browser got an error , your option is try to "reload " full page manually …
roon is the “super specialised” browser here, with same previous/next button too :wink:

Hey @Michael_Harris Michael I can play an 11gb DSD256 album once a day without skip or interruption using Volume Leveling. Mostly seems to be for files that I have one copy of, often flacs not even uncompressed ones, so often I didn’t make them. I use PerfectTUNES on them and it’s happy the aren’t problems with them. My Roon Core is based on a AMD 3900x with a NVIDIA 3080ti so definitely not resources, run a managed Unifi based network so easy to check logs on ports, devices involved are connected to It doesn’t happen often but on two of my endpoints they mute themselves thinking they need to protect themselves from what just happened. So requires getting to remote…

Will shut VL off but without logs of which songs, from which location it is hard to recreate. I can understand Roon waiting to control resources and what happens to keep requirements down but we are asking for a Switch.

Roon is applications that use database, network connections, servers that check metadata accuracy playback files use resources efficiently, it interacts with different devices, does it on Mac, Windows, Linux and it’s varients. I am more than understanding how complex this is. Sometime do want to poke the beast and say this feature might be nice. :wink:

So out of interest most Flac file’s (80% of my library is Flac) have a level of compression and I wonder if that has an impact in this area.

Do DSD files have compression. I have not used VL now in a couple of years. I would like to use it again, but not if it is causing music to skip.
Good to know you don’t have the same problems with DSD files.

DSD use more network resources than flac
DSD64 stats ~3MB/s
DSD512 ~18MB/s
FLAC ~ 800/1600 KB/s

playing music don’t consume cpu time but some roon background task can consume it (.audio analysis etc…)

Enrico Flac files are compressed (zip style), that was my context. I did not know about DSD files which is what Jerry is saying works fine as I do not own any DSD files.
Flac files have to be uncompressed to play and many people have had issues with Roon skipping tracks with Volume levelling and especially with Cross Fade enabled as that requires a second to be uncompressed and levelled at the same time.

I might get 1-2 skips a week.

Enabling or disabling volume leveling make 2% difference on one core. No doubt some have troubles for me it happens so little I would love to log. Problem is it often lead to tunes not playing. Leave it one for dogs and cat.


1 Like

+1 agree. It should not just skip the music. It’d be better to allow user to decide in system preference setting for skipping or waiting till the file can be loaded again


I did try disabling volume leveling for a week no difference music is still stopped when not at home.
Leaving Apple Music on instead. Hopefully it will be sorted eventually.

Hasn’t paused in quit some time now month later.

This is happening again…

My internet is slow, I only have ADSL, my family watches Netflix in the evening, maybe some download is involved and in such moments, my Roon is unusable. I constantly get the ‘TIDAL media is loading slowly.’ message and Roon skips to the next song.

Look at percentages; every song skipped!

I do not expect for Roon to play flawlessly in such occasions. I expect stuttering and pauses. But I do not want Roon to skip to another track! Why does it do so?! How can that be better than resuming?


I would love to see a more informative error message (which may be there but I’m not smart enough yet to know it) when this happens. I have not cracked this nut yet, but switched from a NAS with internal SATA drives to a NAS and external SSD, to a sonictransporter 15 and external SSD without success. I’ve gotten rid of very old 128kbps mp3s and replaced with better, more recent rips of CDs, mostly flacs or 320kbps mp3s. I changed the file and directory structure for more consistency. I updated Verizon FIOS-G1100 802.11bgn router to the Verizon FIOS-G1100 802.11a/b/g/n router… same problem. I bypassed wifi on G1100 router with three Asus Zen AX6600 AX8 WiFi 6 mesh units. Same problem. Not always, but most every listening session. What do all of these pieces have in common? Using 3 Elac Z3 wifi speakers. I’ve tried them wired and wifi’d. I’ve now disconnected two of the three Z3s and now only have one connected directly into a Zen unit connected directly into G1100 router, and now have sonictransporter connected directly into the same Zen mesh unit and am trying again this weekend to see if it really has been the Z3’s all along. :slight_smile:

And tonight I have again frequent skipping, I cannot listen to one whole song…

The same album, same songs, the same time, the same local network, the same internet gateway, but I use desktop Tidal app instead of Roon - playback is perfect.

Update: later I’ve experienced pauses in Tidal playback, but it always resumed (typically after few seconds), never skipped to the next track.

1 Like

With both the sonictransporter and Elac Z3 wireless speaker connected via ethernet to the same Zen AX6600 wifi mesh unit (which is directly connected to Verizon FIOS-G1100 802.11a/b/g/n router), and a 2nd Elac Z3 connected via ethernet to another Zen AX6600 which is wirelessly backhauled to the other Zen AX6600, I am getting most of the songs showing 100% played when I check how the queue played out. I will play the queue longer to get an idea how many fail playing 100% over several hours, then will do the same by removing the second Elac Z3 to see if only the wired Elac Z3 can play music from Roon without having a load failure.

I agree with the subject of this topic - it makes no sense to skip to next track when there is a buffering problem - a pause would be less painful. Could someone at Roon make a definitive statement as to whether this is possible or if there is some technical reason why skipping to next is unavoidable?


Oh. My. God. This ruins (Roons) everything.
So I really have to go back to Spotify?!
Has a member of the Roon team come in here to at least give us a hint at how hard this is to fix?

It’s an enjoyment killer!
Just pause… give a message… Pause on time out if you have to.
But DON’T skip the damn track, Roon! (and immediately play it too! so what was the issue anyway?!)

I’m so upset actually.

This needs sorting out, or we need to be addressed.

And while I’m here, let me say that this has only been an issue for me with the iFI Zen Stream.
Tip: Don’t get it. I don’t even know where to begin with it’s confusing UX and their contemptible support “service”.

I had none of these issues with Chromecast Audio. Zero. it cost 30 bucks, not 400.