Please make it NOT skip songs when "audio file is loading slowly" error occurs

Yes, it really ruins the mood of listening music.

Come on, support team, please fix the stability issue as the first priority!

It still happening as present with the latest versions.

4 Likes

Yes please! This skipping is very annoying. The slow loading shouldn’t be happening either, but that’s for another post.

2 Likes

It would be fine if there were gaps when playing from the Internet, I have such a problem when playing local files stored on the hard disk, which is really strange.

1 Like

Yes, I have my files stored locally on SSD with 1G network and the Roon server not high CPU, that’s unacceptable to skip music.

2 Likes

Yeah I would love to have this changed as well.

1 Like

I’m fed up with this - is this issue will ever be fixed??

Yes, my network connection was bad. I want Roon to pause, stutter and endlessly retry. I DON’T WANT ROON TO SKIP THE CURRENT TRACK!

Sounds like you want a feature request…or a better reliable network perhaps

No. I consider this as a bug in the streaming implementation.

Hello @gmit2 ,

We’ve activated diagnostics on your Roon Core and looking over the logs, it looks like your network download speed drops to below 1Mbps, and you see that message occur. Please see the below log snippet with the issue details:

06/26 01:45:47 Trace: [Matrix Audio mini-i Pro 3] [Lossless, 16/44 TIDAL FLAC => 16/44] [100% buf] [PLAYING @ 10:10/13:49] By the Banks - Wobbler
06/26 01:45:52 Warn: FTMSI-B-OE ti/23E68DA5: poor connection kbps:726.0 (min:1031.0)
06/26 01:45:52 Trace: [Matrix Audio mini-i Pro 3] [Lossless, 16/44 TIDAL FLAC => 16/44] [84% buf] [PLAYING @ 10:15/13:49] By the Banks - Wobbler
06/26 01:45:57 Trace: [Matrix Audio mini-i Pro 3] [Lossless, 16/44 TIDAL FLAC => 16/44] [68% buf] [PLAYING @ 10:20/13:49] By the Banks - Wobbler
06/26 01:45:57 Info: [stats] 172542mb Virtual, 1108mb Physical, 479mb Managed, 365 Handles, 101 Threads
06/26 01:46:02 Trace: [Matrix Audio mini-i Pro 3] [Lossless, 16/44 TIDAL FLAC => 16/44] [42% buf] [PLAYING @ 10:25/13:49] By the Banks - Wobbler
06/26 01:46:02 Warn: FTMSI-B-OE ti/23E68DA5: poor connection kbps:691.5 (min:1031.0)
06/26 01:46:07 Trace: [Matrix Audio mini-i Pro 3] [Lossless, 16/44 TIDAL FLAC => 16/44] [20% buf] [PLAYING @ 10:30/13:49] By the Banks - Wobbler
06/26 01:46:12 Trace: [Matrix Audio mini-i Pro 3] [Lossless, 16/44 TIDAL FLAC => 16/44] [4% buf] [PLAYING @ 10:35/13:49] By the Banks - Wobbler
06/26 01:46:12 Warn: FTMSI-B-OE ti/23E68DA5: poor connection kbps:666.0 (min:1031.0)
06/26 01:46:12 Info: [stats] 172542mb Virtual, 1108mb Physical, 496mb Managed, 365 Handles, 101 Threads
06/26 01:46:13 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:14 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:14 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:14 Trace: [Matrix Audio mini-i Pro 3] [zoneplayer/raat] sync Matrix Audio mini-i Pro 3: realtime=748292670248098 rtt=500us offset=673658663248us delta=266us drift=-1781us in 90.4085s (-19.703ppm, -70.932ms/hr)
06/26 01:46:14 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:14 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:15 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:15 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:15 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:16 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:17 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:17 Trace: [Matrix Audio mini-i Pro 3] [Lossless, 16/44 TIDAL FLAC => 16/44] [PLAYING @ 10:40/13:49] By the Banks - Wobbler
06/26 01:46:17 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:17 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:18 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:18 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:18 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:19 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:20 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:20 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:20 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:20 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:21 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:22 Trace: [Matrix Audio mini-i Pro 3] [Lossless, 16/44 TIDAL FLAC => 16/44] [PLAYING @ 10:45/13:49] By the Banks - Wobbler
06/26 01:46:22 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:22 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:22 Warn: FTMSI-B-OE ti/23E68DA5: poor connection kbps:646.5 (min:1031.0)
06/26 01:46:23 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:23 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:23 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:24 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:24 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:24 Trace: [Matrix Audio mini-i Pro 3 @ 192.168.1.103:37027] [raatclient] GOT [21892] {"status":"Dropout","samples":6634}
06/26 01:46:25 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:25 Trace: [Matrix Audio mini-i Pro 3 @ 192.168.1.103:37027] [raatclient] GOT [21892] {"status":"Dropout","samples":14132}
06/26 01:46:25 Trace: [Matrix Audio mini-i Pro 3 @ 192.168.1.103:37027] [raatclient] GOT [21892] {"status":"Dropout","samples":22050}
06/26 01:46:25 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:26 Trace: [Matrix Audio mini-i Pro 3 @ 192.168.1.103:37027] [raatclient] GOT [21892] {"status":"Dropout","samples":22050}
06/26 01:46:26 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:26 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:26 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:26 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:26 Trace: [Matrix Audio mini-i Pro 3 @ 192.168.1.103:37027] [raatclient] GOT [21892] {"status":"Dropout","samples":22050}
06/26 01:46:27 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:27 Trace: [Matrix Audio mini-i Pro 3 @ 192.168.1.103:37027] [raatclient] GOT [21892] {"status":"Dropout","samples":22050}
06/26 01:46:27 Trace: [Matrix Audio mini-i Pro 3] [Lossless, 16/44 TIDAL FLAC => 16/44] [PLAYING @ 10:49/13:49] By the Banks - Wobbler
06/26 01:46:27 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:27 Info: [stats] 172542mb Virtual, 1108mb Physical, 479mb Managed, 365 Handles, 100 Threads
06/26 01:46:27 Trace: [Matrix Audio mini-i Pro 3 @ 192.168.1.103:37027] [raatclient] GOT [21892] {"status":"Dropout","samples":22050}
06/26 01:46:28 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:28 Debug: [prebuffer] sleeping in read -- this isn't good
06/26 01:46:28 Trace: [Matrix Audio mini-i Pro 3 @ 192.168.1.103:37027] [raatclient] GOT [21892] {"status":"Dropout","samples":22050}
06/26 01:46:28 Warn: [Matrix Audio mini-i Pro 3] [zoneplayer/raat] Too many dropouts (>3s dropped out in the last 30s). Killing stream

Specifically, please review this line:
06/26 01:46:12 Warn: FTMSI-B-OE ti/23E68DA5: poor connection kbps:666.0 (min:1031.0)

It looks like there are likely there some network issues here, some possible causes may include an underpowered ISP router, misbehaving DNS servers, misconfigured network, or modem stability issues.

Hello,

thanks for having a look!

I already knew that and written in my initial message. I have a terrible Internet connection and occasionally it’s even worse and then such things happen.

So, yes, I know the connection is bad. All I want for Roon is to continue retrying, no matter if that would result in stuttering and bad quality (*) - it is understandable it cannot do better if connection is bad. However, I don’t understand in which exactly situation the current strategy of skipping the track would be better than retrying.

(*) Roon might temporarily reduce the requested quality of Tidal stream, but that would really be a feature request and I’m not asking for that.

2 Likes

Hi @gmit2 ,

Thanks for the clarification here. Since these are both suggestions to change how Roon currently works, I’ve shifted your post over to our #roon:feature-suggestions area so other users can chime in with their thoughts on this.

1 Like

@noris, you might rather consider merging this with a thread which already has near 60 votes for this request:

3 Likes

I too am getting tired of this and I don’t have network issues.

Regularly test the connection at over 900MBPS, hard wired NUC10 i7 and hard wired NAD M33.

Started driving me nuts over the weekend, hard reboot on all devices, still does it.

Doesn’t matter about the speed on a speed test as much as the end to end from the streaming service and your system. This can be anything depending on how far you are from their node and other network connections in the path. Propagation delays being the worst thing.

A vpn connection will just make matters worse. Turn off your modem and router for 15 mins then see if that clears down any routing issues you might have.

I HATE THIS SKIPPING BEHAVIOR SO MUCH! Please give me an option to make it stop.

I’m playing a local FLAC from an internal SSD in my ROCK to a streamer six feet away. Why on earth is it skipping tracks? This problem seems to be much worse with 2.0.