"Poor Connection" Errors in ARC on Wi-Fi

Hi Connor, the same here in Italy, every time there’s a “poor connections” at horizon and didn’t load anything

I tried to uninstall/reinstall but now I can’t open the app … it’s loading endlessly trying to see the core

I came here to post about this issue and found this thread was 3rd from top. I used Roon ARC since it came out without issues. I liked it very much as it is not affected by cell phone transitions between WiFi and cell network. I haven’t used it for several days. Today out of a sudden I get “Poor connection. Try again.” while I am on my WiFi. What’s interesting, when I press the Play button it plays whatever was in the queue from last time but I am not able to browse, but I see the recent activity.

I didn’t quite understand the post about this issue being “relieved”. Was it a Roon network issue? Relieved?

P.S. Rebooted the PC withe core, nothing changed.

Hi @G_P,

There was a server outage preventing users with port forwarding properly configured from accessing Roon ARC. We identified and resolved the issue two weeks ago on November 14. For the vast, vast majority of users affected, stabilizing our server issue fully resolved the issue.

Since the server issue was resolved, my previous inquiry was to help identify users who are having unrelated connectivity issues that share the same symptoms as the general outage. It’s likely that the issue both you and @Alessandro_Bianco are facing is a separate networking configuration problem. We will happily investigate in a dedicated thread. Thank you for the report, and stand by for a more detailed response shortly once we’ve investigated diagnostics.

I’m seeing the same thing, on my home network. Regular Roon works fine wirelessly and wired in this environment. (Network details are in my profile.)
Same problem when I turn WiFI off on my iPhone; five bars of 5G, “Poor Connection”.
The Settings>Roon Arc inside Roon says “Ready”.
ARC worked fine the last time I tried it, maybe three weeks ago, both on WiFi and cellular. There have been no changes to the network.

Hi @connor,

Thank you for the response. I hope you can find out what’s going on. I can add that I get the same “Poor connection” when I am on cellular data away from my WiFi. That’s on my Android Pixel 4a phone. I installed Roon ARC on a Samsung tablet and it works fine on the same network at home (except I discovered that it forces a portrait mode, which I didn’t like). I haven’t touched anything on my network since Roon ARC worked very well on the same phone. My core is on a Windows 10 PC. Regular Roon works fine on the same phone and other PCs at home.

Same error here, both on Wi-Fi and cellular my core is on an Intel NUC7i5. Rebooted twice to no avail.

In Roon ARC app, settings and reset Roon ARC solved my issues.

1 Like

Solved. Thanks. I didn’t remember that option was there.

Same here. Thank you!

Pinging @connor. It explains why when I installed Roon ARC on a tablet it worked on the same network fine but the phone had this problem even on cell data. Hopefully the development will take a note of this case. The problem was purely in the Android app. By the way, I erased cache of the app on Android but it didn’t help and the side effect was that album art became grey boxes instead of images. It didn’t occur to me to reset the app and I didn’t want to reenter the credentials.

I’m on iOS so might be independent of OS.

1 Like

Had this problem on iOS as well. Had to reset in the app and in Roon (reset port). Works again.

Resetting in the app is not a problem. Resetting in Roon cannot be done remotely, so I had to wait until I got back again.

What did you mean by “reset port”? Change it? Did you try without doing anything to the Roon core? Resetting the app only worked for me and others. I didn’t touch the core.

Resetting the app didn’t do it for me. So I look at Roon settings and did port-reset:

After reset, it worked!

1 Like

I had the same problem with poor connection. I did “reset roon ARC” from my iphone, then I logged in again and the problem solved!

Hi @Alessandro_Bianco,

I wanted to reach back out since some time has passed. Are you still encountering occasional “Poor Connection” errors in ARC?

Reinstalling the app works for some users, but for users with larger libraries or significant amounts of local content, a reinstall will also prompt a resync that may take additional loading time. We’re here to investigate if you’re still having a problem, in any case.