Popping noise on particular Tidal tracks from Sleaford Mods [Resolved - Clipping]

Roon Core Machine

Windows 10 Gaming Computer, Intell i7-9700K CPU, 32 GB RAM

Networking Gear & Setup Details

Matrix Audio Element H USB Card in PC, USB cable direct to DAC.

Connected Audio Devices

DAC is Matrix Audio x-Sabre Pro; xlr analog cable to Cambridge Audio CXA81; Harbeth P3ESR

Library Size

36,000 on Roon

Description of Issue

I get popping/crackling sound on just a few tracks in the same place on the track (ie not random). I only get this problem when running through my Matrix Audio X-Sabre Pro and only when using sample rate conversion. If I use different system (Home Theater but audio going through Sonore Microrendu) there is no problem. If I bypass X-Sabre Pro (direct USB to CXA81) or turn off sample rate conversion, there is no problem. As long as I am going through the DAC and have sample rate conversion on, it occurs if I output through normal USB port (bypassing Element H card) or use MicroRendu to send to DAC. I have been using this system for months with no issue. Right now, it is only doing it when I am streaming on Tidal Sleaford Mods, Spare Rib, “Elocution” “Mork N Mindy” and “Thick Ear.” However, I heard it on another track a week ago, but did not bother to write it down, and now cannot find any other tracks that this happens. I realize this is minor if it is limited to 3 tracks, but I find it very odd given that it goes away whenever I leave X-Sabre Pro out of chain or turn off sample rate conversion. I am worried that it will start appearing elsewhere. Very strange.

Sounds like clipping to me, since it’s exactly reproducible.
Also, upsampling can cause samples to clip that don’t without.

Activate the clipping indicator (1-4) and watch it turn red (5) when clipping occurs and then adjust (6)…

1 Like

Thank you so much. That worked. Turned on Headroom management, and it got rid of most of the “clipping,” then turned on volume leveling, and it was all gone. I really was not familiar with this functionality at all, so thanks for that. I will say that I could not get the red light to come on, but the problem is still fixed.

Seems your problem may be solved but was not caused by clipping after all?
That’s strange!
If it were clipping causing “the popping noise”, that signal path indicator must briefly turn red when activated, and an ever more negative headroom adjustment value will finally inhibit clipping.


Of course, volume leveling may well mitigate clipping, if the respective files carry sufficient negative offsets in their tags.

I am a little embarrassed that I did not recognize this as “clipping” in the first place, and how easy it was to fix. I can’t tell you how many configurations of my equipment I did trying to figure this out.

Not sure why I can’t get the red light to come on, but you have to turn on headroom management to turn on the clipping indicator, and once I do turn on headroom management, 90% of the clipping goes away. I will be keeping on eye on it. Thank you again. I had just discovered a few other tracks that had the same issue, so this was turning into a problem.

1 Like