Pops and Bangs between Tracks - Hifiberry Digi2Pro Hat and External DAC

Roon Core Machine

Toshiba Portege Laptop - Core i5, 8GB ram, win 10.

Networking Gear & Setup Details

Ethernet, Asus RT-AX92U, 500MB fibre to property. WD Mycloud NAS as music server

Connected Audio Devices

Raspberry Pi 3b with Hifiberry Digi2 Pro hat, Ropieee software
External DAC

Number of Tracks in Library


Description of Issue

Since changing from a Hifiberry DAC to a Hifiberry Digi2 Pro with an external DAC I now have pops and bangs between some tracks. Seems to coincide with format/bitrate changes - especially from MQA to FLAC and vice versa. Less noticeable on a bitrate only change, but still present. Happens during streaming or playing from local NAS

I have tried changing the Resync delay (increased to 500ms) and buffer size (tried from minimum to maximum) settings in the Roon software, but the problem persists.

We’re missing vital info including audio and device configs, but a wild guess points to your incognito DAC…

The external DAC is connected by coax. Inside the DAC there is a S/PDIF to I2S converter which feeds an I2S AD1862 DAC. Max 24bit 192kHz. The DAC doesn’t do it with any other source connected - e.g. CD/DVD etc.

I am assuming this has to do with buffers during the change from one bitrate to another. It’s certainly most noticeable when streaming and the source changes from MQA to FLAC.

I thought this is what the Roon resync delay setting is to sort, but in my case it doesn’t, so it must be something else.

So, I’ve switched my streaming source from Tidal to Qobuz and this issue has resolved itself. Seems to be linked to MQA on tidal and switching between that and normal FLAC or MP3 at differing bit rates.

Changing bit rates up and down on Qobuz is absolutely fine, no issues at all.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.