Pops (clicks) on C658 when skipping MQA tracks

Roon Core Machine

HP EliteBook 820, WIN10, I7, 8GB

Networking Gear & Setup Details

Amplifi HD, endpoint and core on WIFI

Connected Audio Devices

NAD C658

Number of Tracks in Library

120 albums on tidal (1480 tracks) - no locally stored files

Description of Issue

I browsed the forum and came across an old issue similar to my experience:
(Click and pops when changing songs). That case is marked is closed with the remark it seems fixed. My issue is; when skipping from one MQA track to another, clearly audible pops/clicks occur. It does not occur when playing just FLAC files. The issue isn’t there when just using the BluOS app via Tidal, so I asume it is Roon related!?

Hi Lars,

Not official support, just a friendly fellow user trying to be helpful.

Tthe user had corrected his issue with adding a -3 db headroom management.

Assuming it is not that:

  1. try disabling all processing by the Core, even MQA processing, and just sending the raw file to the endpoint.

  2. then, keeping those settings if the issue continues, I would try, setting your output to the laptop speakers and see if the pops clicks continue.

  3. After that, I would try putting the laptop and the endpoint on ethernet and not Wifi, Reasons below

Having the core on Wifi can be problematic. Roon works by streaming the track to the Core, processing it to PCM (which is a larger stream), and then sending it back out to the endpoint. So, if the endpoint is not the laptop, then you are using the same wifi hop to get music in and out, which can cause issues.


HI Daniel,
thanks for reaching our as a community member - appreciate it.
I’ve tried using a wired connection and also to not let core do any MQA processing.
When skipping a track in a playlist of MQA tracks I still hear these clicks pops.
I can’t tell if it is an issue with the endpoint SW, which is a NAD C658.
would official support normally pick up an isshe posted here, you’d think?

Yes, however, they are probably a bit underwater I suspect with volume.

Did you try using the laptop speakers as the endpoint and did they have the same issue? If no, then it would help to narrow issue down.

Well, letting the PC act as an endpoint the stream is not MQA - it cured the clicks/pops though
…also - it does not happen on FLAC files

Well, that is a step forward. If you set Roon to do the first decode to the PC speakers does it still skip? Or is that how you have MQA setup (I never did ask)

Yeah - I toggled the switch for letting/avoiding the core to do processing - I couln’t hear any difference… :frowning:

So, to be on the same page, when Roon is doing the first Decode and sending it to the Pc speakers, it works fine?

Yep when changing away from the C658 just using a pair of cans connected to the Core PC then I hear no clicks when skipping in an MQA play list if that is the scenario you’re proposing. (I also tried to disable the cross feed filter I have when using headphones - no clicks via cans, either)

Well, then, it suggests the issue is with the NAD audio chain. At this point, going back to the NAD, if you remove the crossfed and having Roon do the first stage MQA decode and setting the NAD to NOT do the render step, do you get the clicks?

ok - thanks for the suggestoin. i’ve tried, but no matter what i set up the signal path always shows the NAD as full decoder. I don’t know how to change that - the drop down decoder capabilites seem to not change it and not the switch for letting core doing the first step - perhaps I’m missing something here?

Well, there are two settings, one to tell Roon what to do, and then on the NAD you have to tell it what to do.

It looks like you have the NAD setup as being the full decoder, so, you should set the NAD in Roon settings to be a Decoder and Renderer.

Some other things to try.

  1. If you have the option to increase buffer size that might help, not all Dac Setups in Roon have the option.

  2. Do you by any chance also have Dirac active? Is so, I would try turning it off and seeing if the click/pops continue.

thanks again for all the suggestions. I have Dirac set to off, and I don’t find the parameter to change the buffersize for the NAD - I recall seing it for anohter DAC.

It might not be there. None of my current DACs have the option. Roon morphs the Device Settings page according to the device.

Hi again Daniel, sorry you got dragged into this, but you asked earlier if there were differences when using the NAD as full decoder or just as renderer. I cant choose that manually, but when using cans and activating that cross feed, I think I get the scenario you was were asking about, and when that filter is applied and the NAD is only rendering the click/pops are not there anymore? The signal path look in the two scenarios like the the below…

Cross feed filter applied - no pops/clicks

No DSP filters - pop/clicking

Hmm,.if that is the case try setting the NAD to Renderer only. That will.have Roon do the decide and the NAD just the rendering.

I would have sworn my first test changing render/decoder settings in Roon did not make any difference. Anyhow - I can now conclude when the NAD is just rendering, the clicks/pops are not there at all when skipping or backing between tracks! …Now i don’t know if there is any down sides with this split, where Roon decodes and the NAD is only rendering - technically the NAD should do both with out the annoying popping, and when using the BluOS app there are no clicking/pop, so I’d still think this is a Roon related issue somehow, which is also why i’ve mailed the support direcly for their postion on it… Thank you for all the kind support and nice chat we’ve had on it… I wouln’t have come up with this idea to work around myself, honestly :slight_smile:


There should be no difference whether Roon or the device is doing the first unfold.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hey @Lars_Floe1

We’re happy to see that the wonderful and talented @Rugby was able to steer you through your troubles. We’re glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones: