Port forwarding for Arc not working

Reporting the same issue multiple users will have due to ISP configurations (in my case metronet in the US) unless I pay the extra fee for a static IP address

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

Frustrating not to be able to use ARC

Antonio, can you provide any additional information on your Metronet connection? It appears you have two routers in your network (this error message is typical of a stacked router configuration). I had the same with my AT&T Fiber gateway/router and my ASUS network I used in place of the AT&T WiFi system.

Does Metronet provide you a router (maybe something from Calix or Adtran)? Do you have another network device connected to the Metronet router?

I think it uses CGNat.

Hey @Antonio_Costa,

Thank you for reaching out for assistance with port forwarding / ARC. After reviewing the information you’ve provided, it appears that you may be running multiple NATs in your setup. Please review our help article on the subject, and let me know if you’re able to solve the issue through the steps provided.

If, after going through the above, you still experience issues, please provide the following information:

  1. Who is your internet service provider?
  2. Please list the make and model of your modem and router?
  3. Do you have any additional network hardware, like additional routers or managed switches?
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
  5. How is your Roon Core connected to the internet?

You may need to reach out to your ISP to ask about getting a static IP address.


I have a Eero router provided by metronet, it is the only router in the network. Called metronet, they advised me to try a static ip configuration, but it is an extra charge

Antonio, it appears Metronet uses CGNAT in their network. The only option is their static IP address offer for the timebeing if Metronet cannot reconfigure your connection to disable CGNAT.

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.