Port Forwarding Issue, Manual Configuration, Linksys

Roon Core Machine

Roon Nucleus+, Version 1.0 (Build 227) stable

Networking Gear & Setup Details

Linksys Velop Mesh network
Base node connected directly to Nucleus+ via ethernet

Number of Tracks in Library


Description of Issue

I’m networking-naive, mostly, and have tried to set up for ARC as a manual configuration. ARC could not automatically configure.

The Nucleus+ is at xx.x.x.xx

As per instructions, I’ve ‘reserved’ that address for the Nucleus+, which is as close as I could find to creating a static IP address. I’ve never seen that address change.

I created a single port forwarding rule for the device using that IP address and port 55000. Rebooted the modem, router, network and Roon Nucleus+ All tests, with or without a VPN, failed with the following message being the latest:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“75.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“xx.x.x.x”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n501\nPAL_UPNP_SOAP_E_ACTION_FAILED\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}

Next steps? @support


And more recently, I have this:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“75.aaa.bbb.ccc”,“router_external_ip”:“xxx.xxx.x.xx”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

The diagnostics you’ve provided suggest there is a redundant layer of network address translation preventing port forwarding.

This can either be at the local-network level (commonly as a result of two routers), or at the level of your service provider (in the form of carrier-grade NAT).

If your setup involves an ISP-provided gateway (modem/router combination) and your own third-party router:

  • In the web administration interface of the ISP-provided gateway (modem/router combination), enable Bridge Mode or equivalent, where the ISP-provided gateway does not have DHCP routing enabled.

  • Alternatively, if you have already created a manual port forwarding rule in your 3rd party router, you can add an additional rule to forward the port through the ISP/second router.

If you only have one router in your setup or your modem is already in Bridge mode, please take a look through our list of known router and internet service provider solutions, as other users may have already encountered the same situation: ISPs and Routers: List of Known Solutions and Workarounds

You can reach out directly to your service provider to ask if they support port forwarding; this question will often enough to prompt them to explain whether or not the carrier-grade NAT they’ve implemented can function with ARC.

More specifically, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

If you’re unable to locate an existing solution in our #support:port-forwarding-resources subcategory, please reach out to the Roon support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hi @Rob_Hanson,

I wanted to reach out, as this topic auto-closed after inactivity. Diagnostics show you might have been able to connect successfully to ARC on-the-go via port forwarding.

Given that our helpful moderators had marked this thread as solved, I’m assuming there was some behind-the-scenes support here on Community? If that’s not the case, we’re happy to assist.


Thanks for getting in touch with me.

Yes, I did solve the issue (which was more about me learning how to do things), with the help of a forum member. Since I had a multiple NAT situation, it was a matter of figuring out how to port-forward from my modem to the Nucleus, if I recall correctly.


1 Like