Port setup for ARC

I have a AT&T UVERSE 5268AC modem and I undrestand I need to add a new application in the firewall section of the configuration to allow assign a port for Roon ARC.

What protocol should use (TCP)?
What application type (FTP, PPTP)?

What other configuration directions would I follow?

Sorry for the basic questions but I am new for networking…

Thanks,
Jose.

It’s TCP. On your Roon control device go to Roon - Settings - Roon ARC to see the port number. You may need to click the down arrow. While there you can also see the IP address for your core machine.

On your U-Verse router create a “pinhole” for your Roon core. It will be identified by the IP address or name. Mine just said Nucleus. About all you need to do is give the pinhole rule a name such as Roon ARC and put in the port number. Then save and exit. That’s about it. Most of the other fields you can leave blank.

1 Like

Thanks for your reply Jim.
I added a user defined application access to my SonicTrbnasport with the ARC port and now it says it is auto configured and ready.
Now the next step is to test it outside my home.

1 Like

I know this isn’t very relevant, but to anyone checking your post out - those with xfinity need to open their port on their router AND modem. I had to on my xfinity modem and all worked after that.

This ARC thing is a GAME CHANGER! Just what I’ve been wanting.

I tested ARC just with the cell signal (2 bars out of 5)
And sometime tells me cannot find the core other times says poor connection (retry) and when it connects have constant dropouts every few seconds of playing.

It seems it requires a strong cell signal or some optimization.

Any advice?
Thanks

Jose, cell signals based on bars can be misleading (more bars does not always mean lots more bandwidth for data services such as Roon).

Have you gone into Roon ARC’s settings within the app and set the streaming options for lower-bandwidth Roon streams? This may help, although it may affect perceived audio quality.

Thanks for the clarification and tip Robert.
I changed the settings to Bandwidth Optimized for celular data. Unfortunately I still get the wheel and after sometime the poor connection message.

Hi @Jose_Gomez,

Are you still seeing dropouts from low bar cellular connection while streaming music with ARC?

If yes, do you still see this issue when your cell connection is stronger?

Thanks!

nathan

Hi Nathan,
Yes, still having the issue. If I am within the range of my WiFi the ARC works great and love it but if I am using celular connection I have continuous drop outs.

@Jose_Gomez, if you go outside (or in your home) and run a Speedtest on your mobile device with WiFi off, what speeds are you seeing?

@Robert,
Here inside the house with WiFi off are:
Download 14 Mbps
Upload 6 Mbps
Bandwidth 13.2m

Hi @Jose_Gomez ,

These are very low speeds, Roon uses the Upload speed when sending data to your ARC remote, and if you only have 2 bars of signal, it’s going to be a bit difficult to connect to the Core.

Are you able to upgrade your home network speed at all or plug in your Roon Core via Ethernet at the very least? Having an Ethernet connection may significantly help.

Hello,
My core is connected via Ethernet to an audiophile switch that is connected via Ethernet to my Uverse modem.

Hello @Jose_Gomez ,

Are you able to temporarily bypass the switch and plug in the Core directly to the router? Are there any faster speed plans in your area?