Possible connectivity bug (Nucleus/MacBookPro/Dragonfly Cobalt to Nucleus Focal Arche)

My Nucleus works flawlessly with HDMI to Anthem AVM60, USB to Focal Arche, MacBook and numerous Apple HomePods with or without Chromecast video)

However I seem to have noticed a sequence that causes a problem that requires a shutdown to resolve.

If I choose Dragonfly Cobalt connected to my MacBook Pro as the endpoint it works great… but then I cannot switch to Focal Arche as the endpoint, not even after a restart of the Arche or a restart of the Roon. The Arche remains listed as an available endpoint, I can select it but when playing a song it does nothing. I can successfully choose all other endpoints which work.

Turning off and turning back on the Nucleus resolves the problem, then all endpoints are again available.

I know this is likely a unique scenario but clearly a bug. Any suggestions?


Hi @Paul_Blaik,

To clarify here - the Focal Arche is connected to the Nucleus, not the Macbook, correct?

Instead of rebooting the Nucleus, are you also able to re-establish communication by unplugging and re-plugging the USB to the Arche?

Do you see any specific errors appear?

Hello @noris

Yes the Arche is connected via USB directly to the Nucleus. I tried turning off & on the Arche. I tried restarting the Nucleus but I did not try unplugging the cable and plugging it back in. Turning off the Nucleus and turning it back on solved the problem.

There was no error message. I could choose the Arche as the endpoint it would just not play songs. All other endpoints worked fine.

Again, all of this is following using the Dragonfly/Macbook as an endpoint, then attempting to switch back to the Arche.


Noris I had the same problem again today. I did not reset or restart the Nucleus following the use of the Dragonfly on my iPad this time, but again the communication between the Nucleus/Arche was lost. I unplugged the USB cable from the Arche as you suggested and that worked.

Any idea how to prevent this problem?


Hi @Paul_Blaik,

Can you please let me know the exact local time + date + track you experience this issue next on?
I would like to enable diagnostics mode to see if we can gather more clues through logs.

@noris so in addition to the scenario I explained previously… I noticed the problem is an expanded issue. If I choose another device/endpoint prior to the Focal Arche, then switch to the Arche, that causes the issue.

Today at 8:12 PM, I used Roon to play Young Folks - Peter Bjorn and John from Tidal, I originally selected AnthemAV endpoint which is connected via HDMI, then immediately switched to Focal Arche which is connected via USB song would not play. Unplugging the USB on the Arche and reconnecting solved the problem. This exact same scenario played out before. Really the same scenario as my prior experience explained in the original post. The similarity is choosing a device prior to the Focal Arche, then selecting the Arche - thats when a problem occurs. If I select the Arche as the endpoint first - I do not have this problem.

Hope that helps.

1 Like

Hi @Paul_Blaik ,

Thanks for the timestamp and updated info, I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis. Once this is received, I will ask our team to see if logs contain further clues.

1 Like

Hello @Paul_Blaik ,

Hope that you have been well and thanks for your patience here while our team reviewed logs for your case.

According to logs, it looks like Roon requested the Focal to switch to 44.1/32 and it refused to perform the sample rate change.

Are you still seeing this behavior on our latest release? Have you by any chance reached out directly to Focal support regarding this issue?