Possible to run Roon+HQP on a server and stream to another PC connected to a DAC?

I have successfully configured the following:
PC with Roon + HQP upsampling to 192 to my McIntosh D100 DAC (and it sounds great)

I’m wondering if the following is possible?
PC with Roon + HQP upsampling to DSD256 and then streaming wirelessly (5GHz) to a laptop with Roon in another room connected to a Lampizator Atlantic DAC.

I’ve installed Roon on the laptop and I can “see” all the media files on the PC. The laptop and Roon also detect the Lampizator DAC.

I’d rather do the “heavy lifting” on the PC and stream the results to the laptop and then on to the DAC. Is this possible, or do I need a dedicated “Roon endpoint” connected to the Lampizator DAC?

I see one of the output options on HQP is “Network Audio Adapter” and then there is a dropdown to select a device. How to I get my laptop to appear as a device in the drop down?

Edit: think I’ve found it:

There is a Network Audio Daemon you can install. I installed this on my laptop. If I now select Backend->NetworkAudioAdapter under Device I can now see “default: Combo384 ASIO 1.03” which is the correct driver for the Lampizator DAC running on my laptop.

I’ll give this a try tomorrow. This afternoon was the first time I installed Roon and HQP, so I’m definitely making progress. The next thing will be to experiment with the various HQP filters/settings to achieve DSD256 upsampling for my DAC. I’ll then investigate having a dedicated Roon endpoint rather than a laptop connected to the DAC.

@leftside Let us know how it turns out :slight_smile: Apologies if you already know this, but there is also a quite active thread specifically for HQPlayer’s NAA over at Computer Audiophile. Lots of good info and the developer is always around. He’s active here as well but there is even more HQPlayer discussion over on CA.

It’s all good - I have it working. I now just need to know what settings I need in HQP to upsample to DSD256. It’s not entirely obvious. I see “Sample Rate” and “Bit Rate” I’ll head over to Computer Audiophile. Thanks.

Edit: I found this guide on here, but it seems out of date:

I see I need to set the bit rate to 11289600 for DSD256, but I don’t see that option on my HQP. I’ll do some digging and see what it needs to be with the new player.

Yes, the drop down menu for DSD bitrates changed slightly since then. Now you would choose “44.1k x 256” in the “Bit rate (/ Limit)” menu as seen below. If your DAC is capable of 48k DSD rates, you could set the limit to 48k x 256 and enable Auto Rate Family and it would use the appropriate 12.28 rate when playing back 48/96/192 material. Then set SDM playback in the main playback window. Hope this helps!

That above picture was useful. I did figure out the correct bit rate. The piece I was missing was setting “SDM playback” in the main window (it’s the small dropdown box to the far right) and I also had to turn off the SDM DoP. All good now thanks :slight_smile: