Post Update lost speakers (KEF LSX)

Core Machine (Operating system/System info/Roon build number)
PC, Falcon NW, Have had issues with Realtek audio. Roon version 1.7 build 667
windows 10 pro Version 2004

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Araknis router, has worked without problem.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
KEF speakers connected to ethernet, Naim Unity Atom ethernet (headphones).

Description Of Issue
I clicked on update when prompted. Next thing was that the speakers were not recognized. I rebooted computer, no difference. Found LSX listed and was not able to change any parameters.

Tried the Naim, got sound but only one channel and sounded badly muted through headphones.

Hi @Clifford_Schoer,

Can you please share a screenshot of your Roon Settings -> Audio tab? Is there any change in behavior if you try to reboot your PC?

I re plugged in the KEF LSX, they showed up.
Are now connected over ethernet.
Sound OK.

1 Like

That’s fantastic news @Clifford_Schoer, thanks for the update!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.