Powering the Extension Manager from the Core

Over the holidays I decided to set up the Roon Extension Manager on a Raspberry Pi.
I decided to set it up on a Pi Zero W 2 running dietPi, the set up was super easy and everything went well.

When I went to move it from my desk to connect to ethernet near my core I got thinking… I want this to be on the same time my core is on (always, unless the power has been out), I don’t really want to manage it’s power separately or add yet another USB power supply, so wondered could my NUC8 USB sockets provide enough juice to power this little computer?

I very quickly got my answer, NO. It would power down, or not be contactable.

So is there a way to make it work? Maybe.

First thing I tried was setting the performance settings to the powersaver mode in the dietPi UI, limiting the processor to 600MHz. The issue still existed.

I maybe should have tried to get the Pi Zero version 1, the quad-core processor on this new model
just pulls too much power. So next thing I tried was to shut down 3 of the cores.

I edited the /boot/cmdline.txt file and added ‘maxcpus=1’

On reboot I can now see the number of threads per core is reduced from 4 to 1.

Wanting to give the single core are much headroom before it runs out of amps, I decided to kill the HDMI output, as I’ve see it reported elsewhere this can give 10-15mA reduction in power draw.

So in the dietPi UI I disabled the output, and verified on reboot that the HDMI was off via ‘/usr/bin/tvservice -s’ command.

The extension manager has been running for over a week and I no longer see the issues I did before. I know this is a niche case, but I found it fun trying to detune the computer to the point where it could run from the NUCs USB sockets. Hope it helps someone.

EDIT: Found out that installing a new extension was enough to cause the unexpected shut down, when the package was being extracted. So be warned this is probably NOT a good idea :smiley:


The thing that demands the most power is probably the installation of an extension, when the Docker layers get downloaded and extracted.

Keep in mind that if the power to the Pi just drops when you shutdown your core that this dirty shutdown might corrupt your sd-card sooner or later.

1 Like

You are absolutely correct, I tried to install a new extension - download fine, failed on the extraction.
Will need to see if it’s recoverable after work today. I’ll add a warning to my original post.

1 Like