Powernode 2i - Song selection Playback delay

I purchased the Powernode 2i last December to replace the Raspberry PI I was using with ROON. Yesterday I noticed a strange situation when playing a song. When I select a song to “play now” in ROON, it takes approximately 10 seconds to start. I tried another song and it did the same thing. When I select a playlist, it’s also delayed by 10 seconds before it kicks in and starts playing. The rest of the playlist plays fine with no delays between songs.

Not sure what settings I need to look at. There’s no issues playing music from ROON to my iPhone or PC




1 Like

Reboot everything and see if that clears it.

Thanks for the suggestion. I rebooted everything yesterday right after I noticed the problem…ROCK, Powernode 2i and the apps. Still had the same issue

Wireless or wired network connection to the Powernode 2i?

I have a Node 2i and I am here to tell you that Bluesound’s Wi-Fi network stack is a hot mess. I had similar issues with Roon and playback delays (although nothing like 10 seconds). I switched to using an external wireless bridge (wired connection to the Node 2i) and ALL of my Roon playback delays/stuttering issues vanished.

I tried hard to shed light on this with the Bluesound team, but their response was a variation of “…you’re holding it wrong.”


Thanks Kenneth. The Powernode 2i is a wired connection. I contacted the Bluesound team and went through a few trouble shoot suggestions. None of them corrected the problem. In the end they thought this might be a ROON issue and asked that I wait for their response.

Thanks again Kenneth

Might well be tied in with the other fixes mentioned here? Although I agree with @Krutsch - I was never able to get my Node 2 to play nicely with WiFi, strangely less of an issue with a Flex.

1 Like

Have you experienced the same behavior with the BluOS app?

Other than streaming services, I can’t use the BluOS app to play music from my library. I’ve logged a ticket with Bluesound as they said this was an issue that other useers had logged. BluOS stalls when it reaches 25k songs when reading my library. It goes into a loop trying to update the library

I did not have this problem when I was using a raspberry pie HD amp. Nothing else has changed with my set up except for transitioning from Raspberry to powernode.

1 Like

Hi Kenneth.

Do you have the same playback delays and track skipping (you didn’t mention that but it’s something I noticed during my first attempt with Roon) when using BluOS to control streaming to the Node (in other words, dropping Roon out of the equation)?

I’m streaming fine with Tidal MQA > BluOS > Node 2i over WiFi. I had issues when I introduced Roon on a MBP wired into the primary router (Google Mesh). It’s been a few weeks and I could be wrong but I believe I was seeing those same delays/skipped tracks directly on the MBP (output to MPB speakers).

Going to try again in a month after some projects clear up - just wondering.


I am having different issues without Roon. Streaming from TIDAL has been on-and-off (i.e. sometimes it works and sometimes it simply doesn’t start playback) on any song in my TIDAL favorites. Qobuz has been good for me on playback.

For playback from my local library, it’s been rock solid - but I am using my Node 2i at work and it’s wired Ethernet (I can’t join the office Wi-Fi as it’s authenticated with EAP-PEAP (MSCHAPv2)).

1 Like

I have the exact same issue as Edward_LeBlanc, wired and wireless. Even after the last BluOS update no fix. Using the BluOS app, no delay. With roon at least 10 seconds as soon as I start a song or skip a song of skip forward in a song. It’s becoming unbearable and I an starting to regret getting 3 Bluesound devices with roon. My other ROON compatible devices have NO problem playing with ROON (KEF and RPi) from my ROCK NUC.

Hello @Eric_Leport,

Are you seeing this behavior with all three of your Bluesound devices? When this behavior occurs, what are you seeing in Roon? Does the seek bar stay at 0:00 until audio playback beings, or does seek bar begin advancing and some audio is cut off from the track?


Same here… The delays are really affecting my enjoyment of Roon integration (not Blaming… just Stating). I have a Node 2 and a NAD M10 Masters.

Hi John, all 3 Bluesound. Wired and wireless. The behavior is most of the time: 10 seconds before anything happens, the seconds counter stays at 0:00 all of sudden it starts playing at 0:04. That’s when it starts and doesn’t flip to pause (looks like it sort of times out). Both with Tidal and local NAS. Again, no problem with KEF LS50 wireless and Hifiberry through ROON. Only Bluesound gear through ROON.

Exactly the same problem with a Node 2i. No problème with an iPhone as an end point.

Hello @Captain.Planet, @Eric_Leport, and @herdel,

Could you each report back some basic information about

A) What router are you using?
B) How the Bluesound devices are connected to your network
C) Does this behavior occur every time you use the “Play Now” or “Play From Here” button in Roon?


@john - I’m using the M10 on WiFi.

A) I’m using an Xfinity/Comcast xFi Gateway with their wifi turned OFF.
B) For WiFi I’m using two Meraki MR42 access points.
C) The behavior occurs with play now, next track and play from here.

I recorded a video and posted on you tube via direct link. I can record and upload anything you’ll like.

BTW… My Node2 works perfectly fine so think it’s an issue with the latest BlueOS devices. ¯_(ツ)_/¯

A) I’m using a ASUS RT-AC5300 with latest firmware update. IGMP Snooping enabled (tried disabled same result).
B) I run one Node 2i wired and another one wireless, the Pulse Flex 2i is wireless. All on the same 5ghz channel. All same behavior.
C) The behavior occurs with play now, next track and play from here. Scrolling in a song will often trigger it too.

Thank you.

I experience these issues on my BluOS Roon Endpoints. A Node 2i and a NAD T758 V3 receiver. Very very frustrating. Both are connected on 5G Wifi, line of sight to Asus AC66U routers. Streaming Spotify or playback of local content to both devices using BluOS works without issue. I can also stream 4K content over Plex to other adjacent devices, so it’s not a Wifi signal strength issue.

Issues are:

  1. Track will stop playing mid song, sometimes it will simply enter a paused state, other times it will skip to the next song. Sometimes it will skip several songs until one plays successfully
  2. Hitting play on a song sometimes shows it is playing (playback bar progresses as if it is), but no audio is present. Hitting play again usually results in the song playing properly
  3. If I hit skip on a track, the next song will not commence and behaviour like happens in points 1 & 2 will occur. Roon appears to lose connection to the device momentarily, before it re-discovering it almost immediately.

Either way, very frustrating. I purchased these because they were advertised to work with Roon. I expect is an issue with the BluOS devices - as my Mac Mini, Macbook Pro, Windows PC end-points and iPhone (with Dragonfly Red connected) do not exhibit these problems.

Whether its the fault of Roon or BluOS I do not care, both companies need to work together resolve the issue OR stop advertising that BluOS devices are Roon Ready.

EDIT: Roon Server is running on a QNAP TS453be loaded with 8gb RAM. Roon Database is located on an internal SSD hard drive. I have volume levelling turned on only (no other DSP etc).

To those in this thread that have been encountering issues with playback on Bluesound 2i units to include some or all of the following symptoms:

  • Random stopping of playback
  • Long delay before music starts
  • Music delay then starting 10-15+ seconds into track
  • Quick flash of “pick an audio zone” on controller – a seeming loss of connection
  • Problems using the scrubbing bar – often resulting in one or more of the above symptoms
  • Etc.

I have likewise been fighting with this for some time. I am happy to report that after much testing on my part and sending Roon a variety of extensive writeups, logs after logs, etc… I’ve been told they can reproduce these (some) symptoms. Whew!

Getting past being shown the hand by customer support with basic diagnostics (all of which I performed before contacting Roon) has been a monumentally frustrating experience. However, to Roon’s credit, they have continued to work with me on this.

Now that they can reproduce this in their own environment, they should be able to dig in and determine the root cause and effect a fix. How long? I know not.

My Configuration:
Core & File Repository:

Synology 3617XS+ w/32GB of Memory & running Roon Core on SSD


#1 Wired Bluesound Node2 connected to DAC via Coax out
#2 Wired Aurlic Aries Mini connected to headphone amp via RCA analog out
#3 Wireless Bluesound Powernode 2i connected to speakers via speaker out.
#4 Wired Windows Desktop with sound card and speakers

  • Control of playback from iPhone and iPads
  • Netgear Nighthawk R9000 Router (X10)
  • Current SW/FW on all systems
  • Music Library = ~9500 Albums / ~145K Tracks, Redbook FLAC, HiRez FLAC, DxD and DSD – All on NAS
  • Active Tidal subscription with some Tidal albums added to library (~2700 Tidal Albums in library)
  • Internet: AT&T Gigabit Fiber, 1G Service

cc: @john

1 Like