Prevent down-sampling/not passing high res to DAC

Roon Core Machine

<!|Device name|DESKTOP-9PEQ1LF|
Processor|Intel(R) Core™ i7-10700F CPU @ 2.90GHz 2.90 GHz|
|Installed RAM|32.0 GB|
|System type|64-bit operating system, x64-based processor|

Hi, my DAC (Schiit Bifrost Multibit) is attached to a Macbook Pro via USB, which is connected to my core PC via a home wireless network. I would like to send high res music to the DAC without downsampling, but cannot figure out how to do this. →

Networking Gear & Setup Details

Connected Audio Devices

Macbook Pro 2015, Monterey
OS via WiFi
Schiit Bifrost Multibit gen 2 DAC to MBP via USB

Number of Tracks in Library

152,000 tracks

Description of Issue



I wish to send high res music to the DAC without downsampling, but cannot figure out how to do this or prevent Roon from downsampling. Roon previously did this but not now.
I do not believe it is a streaming/router/network issue as the original sample rate and bit depth is transferred without downsampling when the Mac remote’s device is switched to ‘system output’. The OS mixer however then downsamples before sending to the Bifrost DAC. I have a Qobuz subscription specifically for streaming high res audio to the Mac within Roon.
I do not believe it is an issue with the Bifrost as I can stream high res audio to it directly from the Qobuz app. It appears to be an interface issue between the Bifrost and Roon (e.g. Roon does not think the Bifrost can handle high res, so downsamples before sending via Wifi.
Your help appreciated!

Can you make sure you’re using Exclusive mode (as in the first screenshot), and disable sample rate conversion. What output to you get now?

On the 2nd pic, the Quality is due to using OS Mixer. Try Core Audio.

On the Bifrost, you can also check the device audio setup where maximum rates can be set. It might be that the value there changed.

Thanks Martin. Yes, using exclusive mode and disabled sample rate conversion - No change.

Thanks Big Dan. What I don’t understand is the sample rate option is not available in device setup when the DAC is connected to the Macbook Pro, but is when connected using a Windows laptop.
It does not downsample when using the windows machine.
But also sometimes when connected with the Mac it does not downsample. I cannot figure out why!

With Windows, you might be using the Schiit USB drivers. Under Mac, it might be dictated by the Mac audio settings. Did you try making sure it is using Core Audio and not System Output OS Mixer.

1 Like

Yes, core audio selected, exclusive mode etc. If I unplug the USB cable from the DAC and replug, this will now enable bit-perfect transmission to the DAC. Then the PCM and bitrate options become available in the device settings. USB cable verified on cable tester, running on powered hub etc.
Bizarre, idiosyncratic, annoying behaviour I do not understand! It is clearly a Mac-Roon-Dac interface/driver/software issue…

I havent yet heard from a Roon technician (are you out there?..)

Can you explain this. Is the connection to the DAC passing through the hub?

Yes, by using a powered hub between the laptop and the DAC I seem to avoid stopping and skipping tracks, which was happening frequently with the Mac (some USB ports not even recognizing the DAC without using the hub).
It doesn’t have any effect on the intermittent downsampling issue.

Hubs are notoriously bad to use when mixed with a DAC and are best avoided. If you change you system audio settings to be higher say 96/24 does this change the dacs output in Roon? If so then something is stopping exclusive use or its just not seeing what the DAC is capable of. This could be the cable or combination of both cable and hub.

Thanks for the suggestion, but the hub actually enables the Macbook Pro to detect the DAC - it won’t without it. Strange, because an older Macbook Pro did not need the powered hub to detect the DAC (things should be getting better, not worse with newer machines!.. part of the reason I am in the long, slow process of completely de-appleising my life). The hub made no difference whatsoever to the older machine regarding the downsampling issue. The only thing that seems to work is if I unplug the USB cable from the DAC and replug, then the higher sample rates become available in the device’s settings and I get bit-perfect playback. Not so if I unplug the USB form the Mac and replug (go figure…).
This is with using good cables (verified on a sophisticated USB cable tester).
This all tells me there is a software/interface issue with ROON and Mac.
I still have not had any response from a ROON technician - is anyone at ROON reading these appeals for help?

Can show Roon Audio devices settings page where you enable disable devices. One image without the device enabled the other with. Also post a screen grab of each page of the audio devices individual settings. Maybe worth resetting to defaults and see if that helps.