Primare NP5 - RAAT access gone

Core Machine
Windows10 pro 64 all updates to current OS applied.

Network Details
Linksys Velop Dual Band, ethernet from router to core.

Audio Devices
Primare NP5 - ethernet connection.

Description Of Issue
After recent Primare firmware update & also app updates, developer (Roon Ready) access to the Primare NP5 is no longer an available option in settings/audio.

iOS/iPadOS/Windows10 all affected.

The Chromecast & Airplay options are still available.
The core machine has been rebooted with no success in restoring access.

To trouble shoot, I suggest rebooting all the equipment (Router, switches, Roon Core, audio devices).

I had a quick look of their published firmware release notes … but did not see anything of significance.

Have you connected contacted Primare?

Assuming that’s “contacted” not yet, only discovered the problem a couple of hours ago. They never respond at weekends but i’ll be chasing them on monday.

Yep, post now corrected.

I can confirm this is the case with all NP5 units I sold and installed for my clients. The OTA update from PRIMARE is unavoidable, so what can be done while we wait for Roon certification?


Try to unplug and plug back your NP5 ethernet cable.
Terry from Primare suggested that and it worked for me.

1 Like

Thanks, that worked :+1:t3::+1:t3::+1:t3:

Hard to do when most are running on Wifi…

Try disabling Wi-fi & re-enabling, it’s gotta be worth a try.

“most” or yours :wink:
To make it work it might be worth lugging it near a cable and plugging in and out. If it works you can then go back to wireless.

1 Like

It’s Mark’s clients so probably easier for them to try the Wi-Fi trick rather than “wires.”

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.