Primare Prisma NP5 uncertified [Solved: Firmware Update]

On 13 July Primare Prisma NP5 became Roon uncertified. Any help!

Moved to #support, someone will follow this up for you in due cause.

In the meantime, what troubleshooting steps have you taken, such as rebooting the Roon Core and the DAC?

Thanks for reply.

I have tried to reboot Roon Core and after I have tried to disable and enable Prisma NP5 in Roon which was not good idea. I couldn’t reenable my device in audio settings which forced me to restore Roon from backup to get back my device. I have also tried with Factory Reset of Prisma but this did not helped too. I have Roon Core installed in Synology.

2021-07-15 17_19_47-Roon

Have you checked whether the NP5 is running the latest firmware from Primare?

Yes, prisma is running last firmware update main, streaming and cast. Main is 1.94.

I too have noticed my NP5 has become uncertified.

Any comment from @support on this?

Yes, mine too! It may be because Version 2 of the NP5 is due out in August but that shouldn’t affect the current model. I bought it as a Roon Endpoint so this is worrying!



My primare np5 is not certified either. It is very sad. Do I need roon now?

I’ve only just paid for my first Roon subscription. I didn’t realise that it was possible that Roon would certify then decertify equipment. I’ve asked for a refund. Shame really. Don’t want to get dragged into a spiral of buying new equipment. :cry:

I would just hang-on.

There’s bound to be an explanation.

Hello everyone :wave:

Thank you so much for reporting the issue you’ve ran into. I’m liaising with our product team to see what might be happening. I’ll follow up with an update as soon as possible :pray:

Problem is that I’m nearly at the 30 day mind change point. First impressions are not good now! I’ve started investing in equipment but think I will bail before I’m sorry. Could become an expensive mistake!

Thanks so much for bearing with me :bear:

Could you please try updating the firmware for the Prisma NP5? It should then be displayed as a Roon Ready certified device.

Thanks in advance :pray:

It’s on the latest firmware and was showing as Roon Certified. Now, suddenly, it isn’t.

Primare NP5 Prisma Firmware 1.94

As told before Prisma is running on firmware 1.94 which is the last firmware from Primare for Prisma. I have done the factory reset of Prisma, this install the latest firmware.
I think after update of all roon devices to version XX.806 prisma became uncertified.

Same for me since latest firmware update. I got a Primare service mail before:

I just wrote to Primare about this NP5 “Roon uncertified” issue and created a support ticket.
They usually answer questions quickly.

So, it looks like it may be down to Primare! I thought it was something Roon had done. I didn’t see the update. Must have happened automatically.

Problem solved by Primare, just restart your device


Yup. Email from Primare and new streaming firmware. Certification is back. Yippee! I thought Roon had removed certification! Silly me! :smiley: