Private Zone not actually private

Core Machine (Operating system/System info/Roon build number)
Intel NUC ROCK / Server Version 1.7 (build 511)

Multiple Macbooks with MacOS Catalina as remotes

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Multiple USB - Chord Mojo and Hugo

Description Of Issue

One 2 different MacBooks running Roon Remote, the locally attached (via USB) zones are not private even though Private Zone is selected. Either Macbook can control (play, select, stop…) the device on the other Macbook.

In fact, if you look at the screenshot below, the Mojo and the Bose Speakers are not attached to “This Mac” but another machine on the network. Both have private zone selected. And the System Output/2796M/Built in Outputs are a compination from both macbooks.

I cannot see the private zones from an ipad or iphone. Only macbooks

That’s why one should not clone OS and software installations from one machine to another.

You should be able to fix this by uninstalling and then reinstalling Roon on one of the MacBooks.

I’m not sure where you got the idea they were cloned installations. They’re actually completely different installs.

I’ve tried to reinstall Room on both MacBooks. No difference.

Because Roon thinks, that these two are one and the same machine. Do they share the same IP-Address or MAC-Address?

Nope. Neither the MAC address or the IP address is the same. Different versions of Catalina too.

I’ve just installed Roon on a 3rd MacBook. Same issue.

That’s a strange one. Maybe @support has an idea what’s going on here.

Hi @mvrlogins,

While Roon may be installed fresh, was Time Machine or Apple’s Migration Assistant used to set up the other Macs?

No , neither were used.

Both are entirely independant setups for 2 different people. The third one is a work issued Macbook with everything setup at work including all software installs. The only thing I installed was Roon and it has the same issue.

This morning I rebooted the Roon Core/Server and all is normal again with no priuvate zones showing out of place.

1 Like

Hi @mvrlogins,

I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

Hi again.

They’re back. Private Zones are showing up from another MacBook.

A reboot of the core did not fix it this time.

Half the zones below, including the Bose (which is marked as private and connected by USB), are on the other Macbook.

Hi @mvrlogins,

Can you confirm what model MacBooks these are?

One is the latest Macbook Pro 16", the other is a Macbook Pro 15" from about 3 years ago.
Both running Mavericks, one 10.15.3 and the other 10.15.4

Roon Server is now Build 528, it was 511 when I first saw this issue.

With regard to the image I posted 2 posts back, when the 15" MacBook is turned off, I only see a single instance of “System Output” and the “Macbook Pro Speakers”.

As soon as the other machine is turned on I see the remaining 4 outputs as well as any other audio device (e.g the Chord Mojo) that is plugged in to that machine

Hi @mvrlogins — I’ve sent you a PM.

Got it. Seems to have solved the problem. Thanks

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.