Pro-Ject Pre Box S2 Digital


(Philo Melos) #646

The new Roonupdate solved the pops between mqa-numbers, decoding and rendering on the Pre Box. That’s a good thing. Only pop is when you pause the music, and play again. I think Roon can fix this also (cause it looks like the above problem).


#647

So non MQA roon does the 1st unfold, I thought for this to happen have to be set as decoder only, good to know


#648

@PhiloMelos does your allo USB Bridge goes offline after playing for 1 or 2 hours and has to be power cycled? I have a nuc with roon core ethernet to allo bridge (and sparky) USB to pro-ject s2


(Philo Melos) #649

No, my USBridge keeps playing for hours, without the need of a powercycle. (Alu case)


#650

Sounds like a possible overheating problem? Which case do you have acrylic or aluminium.


#651

I have both versions (acrylic/alu case) but I never touch them. We get a power cut once or twice a year but that’s it. They are kind of out of sight and I forget they are even there.


#652

I have the aluminium case USbridge and it is left on and always works perfectly, however if you move one from an acrylic case to an aluminium one then the heat sink pads have to be fitted and there is scope for error.


(Magnus) #653

Correct, Roon does that in order to give partial MQA to non-MQA DACs. I have my S2 set as non-MQA, so Roon does the first unfold, then I oversample to DSD. I like the sound of that better than full MQA, and it also takes care of the stuttering problem the S2 DAC has for MQA.

Makes me wonder why I bought a MQA DAC in the first place though :slight_smile:


#654

That makes sense, and even may make more sense to purchase HQP and do all the heave lifting there, Roon as a transport and DAC as a receiver and the 2 unfolds at HQP, don’t you think?


(Sean) #655

Even if the S2 DAC had no MQA functionality, it would still be incredible value (and performance) for the price - only in my opinion of course.


#656

Amazon has them back in stock again but probably not for long.

Silver - https://www.amazon.com/Pro-Ject-Pre-Box-S2-Digital/dp/B073WCRZ79/ref=sr_1_17?ie=UTF8&qid=1526057905&sr=8-17&keywords=pro-ject

Black - https://www.amazon.com/Pro-Ject-Audiophile-Product-Black-Box/dp/B078HVYL3L/ref=sr_1_32?ie=UTF8&qid=1526057975&sr=8-32&keywords=pro-ject

–MD


(A Welshman, currently exiled in Hampshire) #657

Black is not a colour, it is a shade. Just saying.


(Michael Blair) #658

Mine arrived today. I’m trying to install the drivers on my Windows 10 Surface Book. Goes through all the motions, tells me to reboot and then no hey presto, just like magic, no drivers are there. Tried download version and version from disc. Also tried from Device Manager. Anybody know what I’m doing wrong?


#659

It has been recommended that you perform a Firmware update. That is what I did and I have had no issues after that.

Hope this helps.

–MD


(Michael Blair) #660

The instructions to update the FW seem to indicate I either need a driver control panel or to install the FW update utility. Neither of these are working either. :frowning:


#661

Just a thought. Do you have it connected to a USB 2.0 port and not a 3.0.

–MD


(Pawel Walczak) #662

Which Windows 10 build you are using?
Isn’t DAC working just with standard built in USB Audio 2 drivers?


(Michael Blair) #663

Yes connected via USB 2.0 port.


(Michael Blair) #664

Win10 version 1803
Yes working via media monkey with standard drivers. However Roon can’t see the device although in audio settings it flashes up devices connected to this pc but only for a second or so


#665

Open up Device Manager and expand the USB tree.

Pay attention and unplug the DAC and try to determine which one disappears and then reapears when you plug it back in.

Once you identify which USB, right click and then select Update Driver software. One of these options should work.

–MD