Pro-Ject Stream box S2 ultra not showing up as a roon ready device

Core Machine (Operating system/System info/Roon build number)

I am running the ROCK on an intel NUC, the software is up to date. Its working fine.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Archer router, feeding everything via Devolo wireline ethernet over power devices.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

My problem is with a new Stream Box ultra S2. Its connected to my network via 180Mbits/sec ethernet over power. Wireless is off. Its feeding a Audiolab MDAC. I also have my ROCK feeding a Chord 2Qute direct via USB, which works fine.

The problem is that the Ultra shows up as a airplay device.

Is that as it should be? I thought it was a roon ready certified thing that Roon would recognise and interact with directly. It works fine, I can listen to music, it sound good, it is just that I was hoping for more than airplay.

The Ultra is running the latest version of its software.

Hello @Rols,

On the Pro-ject Stream Box S2 Ultra WebUI, head to the “My Music” screen and make sure that the toggle next to “Roon Ready” is enabled.

The Room Ready endpoint will only appear when you have an active DAC output set on the device. It may be worth checking the “Playback Options” screen as well to make sure your DAC is appearing as expected.


1 Like

When I got my Stream Box Ultra S2 about a month ago I had to factory reset and download the latest upgrades a couple of times before it was recognized as a Roon Ready device.

This worked. Yay! There was a Roon option disabled in the MyMusic tab. As soon as I changed this the streamer appeared as a roon device under roon’s settings audio tab.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.