Probably a bad ethernet jack, BUT

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Arris TG1682G, direct ethernet connection

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Recently, I started having trouble keeping Roon ROCK running via the direct ethernet connect. Then yesterday it stopped connecting altogether. Lights don’t come on either on the router or the NUC, where ROCK is located. The same ethernet outlet and cable work fine with other equipment, e.g., a laptop. So, I’m guessing I have a hardware problem with the ethernet jack on the NUC. Does that seem logical? Is there some other possibility I might be missing?

Have you tried a different ethernet cable on the NUC?

And try a different port at the router.

If that still does not work, go into BIOS, take note of the settings and reset them to default, then re-apply your settings.

With no lights, this would appear to be a physical connectivity issue. Ensure the connectors are firmly seated and ‘click’. Some can be slightly odd dimensions and don’t go in as far as they need to without some persuasion. Use a common Cat5e cable intended for data, not something designed for audio. As you have always had issues, a reboot of the router wouldn’t hurt either.

As a further test, if the NUC port is bad then you can plug in a USB Ethernet adaptor and try that (with a different cable and router port). This will possible change the IP address as it will use DHCP by default.

Yes, I’ve tried numerous cables.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.