Problem accessing music files via smb

Roon Core Machine

Nucleus + 32 mb

Networking Gear & Setup Details

Netgear Nighthawk AX12

Connected Audio Devices

Atom Unity

Number of Tracks in Library

721,304

Description of Issue

Since I changed my ISP (Exetel) with static IP I’m having difficulty connecting to the Nucleus using ‘Connect to server’ in the Finder (mac)

I can use Roon through the app on my Macbook and Apple devices but I’m unable to access my library through SMB.
It used to take around 10 minutes of loading for my music folder to display, now I’ve been ‘loading’ for several hours.
This is on both of my Macs.

Since I received the static IP, do I have to setup port forwarding on my modem?
Roon reports that ARC is ready.

Moved to the support area

I don’t know what the problem is with Finder, but it normally should have nothing to do with the static external IP from your ISP. Only your router deals with this.

When using Finder and Connect to Server, what exactly are you entering in Finder?

I go to smb://nucleusplus which is fine
Then I drill down to my music folders and they appear to be loading, forever

Both my internal SD drive and the external hard drive plugged into the Nucleus refuse to load

The internal SSD music folder just displayed, but still not the external
could it be that Roon is busy and is causing problems accessing the music files?

No issues playing music through Roon though.

Ok, at least not a network discovery issue in this case.

It could be that your network is being very slow, so that listing all the folders on the internal drive simply takes very long (how many do you have? I see 721,304 tracks that’s a lot if a significant part is local, and may just be taking time. Is the Nucleus wired? And the Mac, wire or wifi?)

Or there might be a hardware issue with the (external) drive.

At this point, probably best to let Roon’s official support take a look, they can check your logs.

As you are using a Nucleus and paid for support, I am moving your post to the dedicated Nucleus Support area.

Hi Suedkiez,

Thanks for all of that.

Yes, I have many folders and most of the tracks are local.

The Nucleus is wired, the macbook is wifi and my mac mini is wired.

The folders in the both the internal SSD and the external hard drive displayed on the Mac mini, but not on the macbook. I tried to delete some folders on the external drive using the Mac mini and received an error message saying that they couldn’t be deleted.

I think there’s an issue with the number of folders in my music library, I’m now able to copy and add to my music library, but trying to back up the files using Carbon Copy Cloner seems problematic as the source folder won’t load in the backup task. Perhaps it will take several days to load. Can @Suedkiez support take a look at my logs and advise procedures to improve this issue please.

@Paul_Elliott, did you happent to recently upgrade your Macs to OS X Ventura? I did, and from my experience (as well as some other pots I’ve read on other sites), something is wrong with the SMB implemetation in Ventura.

You’d have to tag (@)support, not me :slight_smile: but they should be looking at #support:nucleus-support posts automatically. Just may take them some days to get to you.

Thanks for the feedback, I upgraded my mac mini but my macbook is from 2015 and 12.6.1 is all it could be upgraded to.

I can now access the files but it’s very slow and laggy

Thanks for the headsup @Suedkiez