Problem between Roon and HQPlayer (18 second delay)

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
An abnormal problem …
I installed the Roon core on Mac Mini and the player (HQPlayer) is on a server.
The anomalous problem is that when I send a Tidal song to play, the player takes 18/19 seconds before starting to play the song …
I this normal … ?

I understand that Roon streams the Tidal signal on HQP, but 18/19 seconds seems too much …
and every song of the album being played always starts with 18/19 seconds delay …
Has anyone had the same problem?
Thank you.

That is not normal. I think you need to show how your network is configured.


In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

roon core is installed on a mac mini dual core, s.o. mac o.s high sierra, roon latest release downloaded 3 days ago.
the system is wired, no wifi, modem router of the fastgate manager (fastweb) + tp-link switch TL-SG105E on which the machines are connected (mac mini + server)
the playback device is connected via USB.
the management is via tablet androind huawei (of course the wifi)
I guess I haven’t forgotten anything …

What are your settings on HQPlayer?

i am trying a dac and the settings are:
PCM mode
filter Sync-M
LNS15 shaper
upsampling 88.2 - 96 khz

roon was installed on the server …
roon needs a lot of ram memory
that’s why I moved it to another pc (mac mini)

needless to say, with roon installed on the server I had no latency problem …
I can change the two banks of ram memory on the server and put the roon core back …
but I wanted to understand the reason for this delay by using another pc only for the roon core

I would move the HQPlayer from the server and have it installed on the Mac Mini with Roon, I would think a far better set up which should reduce the latency issue.

in a normal situation … where I do upsampling from pcm to dsd 256/512 … the mac mini is not suitable for the purpose.

Make sure adaptive output rate in HQPlayer settings is checked, not greyed and that should speed things up to about 4 seconds.

you put a flea in my ear :thinking:
I changed the filter and shaper …
now there is no more latency …
it was a hqp set-up problem.
thanks Chris :ok_hand: :+1:

thanks, this particular I missed :+1: :wink:

:+1: :grinning:

One million tap filter at 88.2 kHz means 11 seconds of filter delay alone.

thanks Jussi … I understood it later. :upside_down_face:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.