Problem browsing Roon Community Site on older iOS

I am using an older iPhone which can’t be updated above iOS 12.5.5. For some time now I have had problems browsing the Community Site; e.g. the system wouldn’t recognize a visit to a thread with new messages. The ‘new message count’ would stay put, the software wouldn’t remember the last visited post on a revisit to a thread, etc.

Today I have noticed that the Community Site doesn’t visualize on my phone at all. The browser (tried with Safari and Chrome) simply shows a totally blank page. I have deleted the browser cache on the phone, have rebooted the phone, but to no avail.

So my question is, have the site admins recently done any updates on the Discourse software or components used for the Community Site which would explain this? Have maybe other users noticed problems with the Roon Community Site on (older) iOS?

@Andreas_Philipp1 last night I found unreachable for a while.

All current version of browsers etc.

Not sure if this was a local geographic network issue, or, indeed if related to your problem.

This has been going on for a while. My old ipad mini o 12 loses content shows early posts then revwnt ones are blank

I gave up and use my big ipad on iod 14

Thanks @AA_Parky.

On my laptop and iMac the site shows ok. This is only a problem for older versions of iOS, it seems. And it is very unfortunate, too, because while it may be understandable that some newer versions of apps won’t run on very old iOS releases, this I never have encountered with a web site. From one day to the other, I am not able to access the Community Site on my cell phone anymore.

And as @Mike_O_Neill says, there have been problems for a couple of months, but now it doesn’t load at all. I would love to hear back from the site admins, whoever that may be.

Just a tiny bump …

Any thoughts , I have to sunbathe with a 12.9 rather than my Mini

Life’s tough :smiling_imp:

Same here, iPhone 6 with iOS 12.5.5, the site get a blank page.
If I disable the JavaScript it shows the main page but if I click on one of the topics I can’t see it.

It seems related with some javascript command not supported on iOS 12.5.5 (release on September 23, 2021). Until now only this site isn’t working.

Hi José, same here. The Roon Community site is the only one I have found that wouldn’t work on iOS 12.5.5. I suspect there was some update of the underlying Discourse software which broke compatibility with older iOS.

Tagging @support as no site admin seems to follow this category…

Discourse took support away then added it back in again until jan 2023?

1 Like

Ah, that’s good to know. Unfortunately, the Roon site still doesn’t work on my old phone…

Perhaps roon is on a version without support.

I don’t know about support but the current version used by Roon Labs is Discourse 2.9.0.beta2 from Feb. 14, 2022 which is older than the cited announcement - therefore likely to old to contain the fixes/workarounds implemented for older iOS.

1 Like

Thank you for that info!

It would be great if a site admin would take care of this… And I now understand why this update from Feb. 14 broke the compatibility with iOS 12.5.

Hi All,

Thanks for bringing this to our attention! We have just upgraded Discourse to the latest version, if you were having issues on iOS 12 with Community, please refresh and let us know if its working now, thanks!


Thank you very much @noris for taking care of this. I just checked and my old iPhone is no longer cut off from Roon’s community site.

1 Like

Thanks @noris Roon’s community site is ok now.
I don’t know if it’s related but the main site ( menu doesn’t open on iOS 12.5.5.