Problem connecting to core from android roon remote

I have installed roon server on my ubuntu machine running 16.04. On my android phone, I installed roon remote. When I launch the remote app on my phone, it doesn’t seem to be able to find the roon core even though I have specified the ip address for the core.
The core is connected on ethernet cable to the lan switch, which is connected to the wifi ap, which my phone connects to. I could access the core using the phone on other apps like file sharing and etc. With the exception of roon remote.
Is there any settings on the wireless router / lan switch required?

Best regards

Hey @Chen_Shing_Liu — Thanks for sharing your report with us!

So we can better understand what you are experiencing here, may I ask that you please verify the following:

  • Can you please describe the networking hardware that is in use?
  • Are you able to connect to this Core with any other remotes (phones, tablets, or PC/Mac running Roon)?
  • Have you tried power cycling your Core machine, networking hardware, and the remote?


Also, you should make sure that your ubuntu machine and phone are on the same Wifi subnet.

1 Like

There’s a long thread on the topic already:

I had the same problem with different Android versions and an Ubuntu core for a long time until I turned off IGMP snooping on the Netgear managed switch that sits in between the wifi AP and the core machine.


Hi All,

Thanks for all the help. I found the problem. I had a previous installation in the machine, which I uninstalled but had some left over files in /var/roon directory. Once I deleted everything left over in that directory and did a fresh new installation, the problem was gone. I am not sure why the core did not accept connections if I install without deleting leftover files and directories though.

Best regards

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.