Problem Detecting Audio Outputs

Hi there

Appreciate help - when I launch Roon on my laptop it does not detect my Meridian 818 using ID41, nor my MS 200 out to F80 in Zone 2. It can detect the Apple TV in Zone 1.

I suspect this happens after I use Sooloos Control PC and Control PC somehow hogs these outputs. Grateful if you can support.

Best /bt

My Setup

Zone 1
MC200 x 2 (one master) with Tidal and with Flac files
818v3
dSP 5200SEs
Apple TV gen 4.

Zone 2
MS200 into F80

Core for Roon - Windows 7 laptop (Samsung)

You might want to provide more info on the exact setup of the network and what connects it and how…LAN, wifi, Ethernet over power line etc

If the MS200 and 818 are held hostage, it is most likely by Sooloos Core. What happens if you show down the MC200 running Core and reboot the endpoints?

If it’s Sooloos interfering you just need to reactivate the outputs in Audio Settings in Roon (as if you’d never done that).

Morning thanks Wiz I left out that important information:

  • high speed fibre connection into modem then into 3 asus routers to cover the home. Living Room Asus cable out to ID41 on 818. Roon Core is Samsung Laptop it is wirelessly connected to the network (maybe this isnt ideal?)

Hope this is sufficient thanks !

Hi Ludwig, it doesnt have any effect, I open the Audio window and press the refresh button but the Meridian components do not get detected.

If I reinstall Roon afresh it can detect them, but when I use Sooloos again they disappear

any advice to resolve highly appreciated.

RBM can you set out the steps you had in mind for this solution ? Thanks !

@Beng_Ti_Tan I think you still need to detail more about the network…and I’m assuming you have yet to get any of this working and ithis in not something that worked before but is not working now, after some change.

How are your routers connected? Wifi or LAN?

What are the addresses for DHCP and is this being covered by just the main Fibre connected device? I.e. If your wifi is giving out different pi ranges for the different locations LAN/wifi then roon will only see what is on the core connected address range.

Hi Wiz

Thanks for your continued support. Im getting out of my depth here. I know the routers are connected by Lan cables. On the DHCP I am unsure - can you teach me how to check it ?

Thanks

Wireless for the core machine is certainly not ideal.

If your core is on wifi and that wifi is using a different IP address range then the core won’t see wired connected equipment

If you have an iOS or android tablet/phone maybe you can use an app called FING that will scan your network ( the wifi network ) that it’s on and show you the devices and it addresses its seeing.

In Windows you can find the pi address of the pc in the network properties usually.

Hope that is enough to get you started

Tagging @support in case they have some additional things to look at

That’s odd…so it sees them once?

yes i encountered the problem and then reinstalled Roon from scratch. It saw the Meridian endpoints. After a bit (especially when the Laptop isnt on) I used Sooloos and when I next used Roon, they were gone.

Since I have your attention - why is Roon designed this way to require the use of a separate core device ? This I would think results in issues I encounter, for many household/casual users. But I could be wrong. I am not seeing the benefit this approach brings over the core sitting in a MC200 for example.

Many thanks Wiz for this, so I find the IP address of the end point and same for the laptop. Then how do I force the laptop to use the same address ?

You mustn’t have the same address for each device - they must all be on the same range of addresses … typically they will look like

129.168.1.1 through 192.168.1.254 with only the last of the 4 digits changing.

Your first 3 numbers (192.168.1 in the above example) should always be the same…

see https://kb.roonlabs.com/Why_can’t_Roon_Remote_Connect%3F

BUT as your issue appears to be more related to the endpoints disappearing after they are connected to Sooloos then I think the Roon boys are ones to chime in here as they are veterans in this department.

Hi @Beng_Ti_Tan ---- Thank you for the report and the insight here.

I want to take a step back for a moment and clarify what exactly the issue is being reported. If I am understanding this correctly when you launch Roon on the laptop hosting your core you can see your endpoints without issue. Can you stream to them successfully when they are in an active state (i.e are being seen by Roon)? If you however, navigate to the Sooloos control application and then back to Roon none of the endpoints appear, correct?

-Eric

Hi @Eric

Apologies for my delayed response, I was travelling and didnt check the page. Yes your understanding if correct. I would refine it further to say: when I install Roon or re-install it afresh on my laptop, it can auto-detect the end points if my Meridian 818 and MS200. Then, when I use these endpoints with Sooloos/Control PC, and relaunch Roon, Roon cannot detect or play to these endpoints. This happens anytime after I have used Sooloos - it could be immediately after Roon or even a day or 2 later.

Grateful for any support you can provide.

Thanks /bt

Can you post a screen shot of your audio setting after this disappearance of the zones has occurred?

Hi @Ludwig

OK i will do that when possible this evening my time (Asia)

Thanks ! /bt

Hi @Beng_Ti_Tan ---- Thank you for touching base with me, no apologies necessary :wink:

I would like to grab a set of logs from you, but first I would like to have you conduct a very simple test to see if we can trigger a change in behavior here. May I ask you to please perform the following:

  1. With all applications closed, on the Win7 laptop (Samsung) hosting your Roon core, I’d like you to navigate to the same [directory] (https://kb.roonlabs.com/Database_Location) where your database is located.

  2. Within that directory you will see a folder called “RAATServer” (example below), please re-name this folder to “RAATServer_Old” and then launch Roon. Confirm that the endpoints are still available and then close Roon.

  1. Once Roon has been closed, using the Sooloos/Control PC access your endpoints as you have been and then close the Sooloos control application.

  2. Launch Roon and confirm if the end points are not available.

-Eric