problem importing playlists

Roon Core Machine

Roon ROCK running on dual core 64-bit AMD processor (4GB ram, 64GB SSD, Roon OS Version 1.0, build 256, Roon server Version 2.0 build 1182)

Networking Gear & Setup Details

Asus RT-AX86U router connected by ethernet cables to a NAS (hosting local tracks) and the Roon Rock, Sonore UltraRendu connected to a second access point

Number of Tracks in Library

~30,000 tracks

Description of Issue

Today I migrated from Roon Core running on a Windows 11 laptop, moving to a Roon ROCK running on dual core 64-bit AMD processor (4GB ram, 64GB SSD, Roon OS Version 1.0, build 256, Roon server Version 2.0 build 1182). On the Windows laptop, my m3u playlists were imported into Roon, but on the Roon ROCK they don’t appear.

I initially attempted to migrate the database from the Core to the ROCK, but once everything was set up the system was unacceptably slow. Resetting the ROCK’s settings and starting from scratch seemed to fix the problem. I added my music folders, stored on a NAS, in exactly the way I had added them to the Core. The only difference I can see is that the Core was connected to the system wirelessly, whereas the ROCK is connected by an ethernet cable to the router.

To be clear: the storage location where the playlists are located is set to “Import other playlists,” the playlists incclude tracks from the same watched folder (and no other tracks), the playlists use file paths that match the folders I added to Roon, and the m3u playlist isn’t an exact copy of the tracklist in the directory where the m3u is stored. As I said, the playlists imported properly to the Core, so I can’t understand why them wouldn’t have be recognized by the ROCK.

I’m not sure whether it’s related, but I’ve noticed a minor discrepancy between the number of files in the directory on my hard drive and the number showing up in Roon. (It seems that 3% of the tracks are missing in Roon.) Thanks in advance for any suggestions!

David,

Just assembled an Intel NUC to try out with Roon yesterday - I ran into the same issue attempting to import m3u playlists that worked fine using a Roon core on my PC. The M3U files were both at the root level of the Music drive. Roon Rock on NUCs appears to have issues with relative paths, at least mine does. Spent way too much time trying to get Rock’s playlist importer to work.

The solution for me was edit the M3U playlist in Notepad to use the Rock absolute path (using Notepad’s replace feature). I have seen posts where relative paths did seem to work, so you may need to experiment.

This was the original M3U path that worked with Roon on my PC:

D:\Peter White\Glow\07 - Glow.wav

This path worked on the NUC (USB drive attached to the NUC):

/roon/sys/storage/mounts/Roon_Music_WD_My_Passport_2665_575844324442313546365858_E884-AD16-p1\Peter White\Glow\07 - Glow.wav

What is really odd was my connected USB drive was named “Roon_Music” and Rock added “_WD_My_Passport_2665_575844324442313546365858_E884-AD16-p1” to the path drive name.

Hope this helps.

1 Like

Thanks very much for sharing this, Greg, and sorry for my slow response. It sounds like you and I have run into the same issue. (Since it seems there are a number of us reporting this problem, it seems like the sort of thing that @support might want to look into.)

I’m not sure I understand the solution that worked for you, however. How do I go about determining the Rock absolute path?

Here’s an example from a playlist that successfully important to Roon Core running on an old laptop:

#EXTINF:209,Rhye - Hunger
\[name of NAS]\music\Allmusic\5star - lossless\Rhye\Woman\9 - Hunger.flac

The folder I’ve added to Roon is this one (which appears in Roon in this form):

\[name of NAS]\music > Allmusic

I’ve tried to edit path listed in the playilst in several ways, but none of them has worked so far.

Go to an album that contains the track you want to add to the playlist, under the track listing click the 3 dot menu, click “View File Info”, at the top click “Copy File Info to Clipboard”, paste into a text editor.

1 Like

DavidN,

Rugby is correct about determining he absolute path. That is what worked for me, even though it seems to be incorrect if you look at the absolute path using a Windows PC to view ROCK music storage on your network. I don’t understand why Roon adds so much on to the names of the connected storage drives or why the paths are different.

I have a WD My Passport hard drive named “Roon_Music” for music storage and a Sandisk USB thumb drive named “Roon_Back” for database backup attached to a NUC with ROCK installed.

Roon added all the other characters in the names you see in the network section of my screenshot.

The attached screenshot image also show the ROCK storage path I see in Windows file explorer and below that my playlist open in Notepad showing the track listings with the absolute paths.

Hope this makes sense.

1 Like