Problem installing NAA-image on Rasp Pi

Hello,
Did read some posts about installing NAA-image of Sygnalist and thought it was an easy job to do. I have a SD-card of 32 Gb which I could use for this setup. So I started with this easy job but…

This is what I did:

Maybe too easy for the job?

At the last step, select you mrendu NAA and press “apply”

Then look at your list of NAA’s again.

It’s kind of like doing a ‘refresh’.

All your other steps look correct.

Looks correct, you just don’t need to format the card before flashing, because flashing will overwrite any pre-existing formatting it may have.

Thanks for your fast and helpful answer!!
That was easy and did the job. :smiley:
This is the result:
config audio backend 2021-08-14 133203

Now I’ve got two options extra but don’t know which is the right one. Maybe both are right.
The Raspberry is connected to the Loxjie D30 which is a DAC and headphone amplifier. What should be the best choice?
On this moment (didn’t choose an option) I can’t see in Roon> Settings> Audio this option. Will I see this option after choosing/apply in Config HQPlayer?

1 Like

The USB audio one (middle in your list) is correct.

The bottom one is for the 3.5mm analogue output of the RPi itself, so you don’t want to use that.

No, in Roon you only setup HQP server. Roon doesn’t see the NAA at all.

So you only have to point Roon to your HQP Emebbeded server. Go to “Setup” then “Add HQPlayer” then use your IP address.

This will create a HQPlayer “zone” in Roon

Thanks again for your fast answers!!

That’s very helpful.

But I already did add HQPlayer two years ago for my microRendu-La Rosita.
Should I do this again for this new option? Will both options (microRendu-La Rosita and NAA-Loxjie) continue to exist in Roon> Settings> Audio?

No, then if HQP is setup nothing to change in Roon side.

As I mentioned above you don’t change anything NAA related in Roon.

Press play and enjoy the music !

So when I would listen to NAA-Loxjie D30. I have to choose in HQPlayer Config the Audio Backend option <naa: Loxjie Audio: USB>. But will this be a visible Zone in Roon?

Correct you change NAA on Config web page.

But the HQPlayer itself doesn’t change, so you don’t change anything in Roon.

Roon will play to HQPlayer server and HQPlayer server will play to whatever NAA you selected on Config page.

I think I understand my misunderstanding.
In Roon I see on my display Zone HQPlayer symbol but I named it also HQPd-La Rosita an addition by myself:

So if I will listen to the naa: Loxjie it will be the zone HQPd-La Rosita. Maybe I should change the naming of that zone. And when I want to know to what I’m listening at I have to look in the Config of HQPlayer what I did chose in the Network Audio Backend.

Correct, if you have only one HQPlayer “server” in your house, just leave the name of that zone in Roon as the original “HQPlayer” name. As I wrote about, you never need to change anything in Roon after that.

In Config web page, you select which NAA you want.

Roon always plays to the same server. HQPlayer will play to NAA you select in Config page.

Jussi might have 5 different HQPlayer servers in his house, for his development work, so then he needs to give each a different name in Roon. In Roon there is nothing at all related to NAA.

Thanks for your help dabasgoesboomboom. :smiley:

1 Like

No worries.

The RPi4 + NAA image is a really top notch solution. RPi4 has overcome the major issues of the earlier RPi models (with USB).

I use one at DSD256 (with EC modulator) very reliably. Never one issue.

My Rendu is also reliable but a lot more expensive !

1 Like