Problem missing 1 or 2 album and restoring database plus typo

After the latest update to OS build 227 on ROCK, my ROCK has a slight issue. Everytime I restart/reboot the ROCK server, I keep missing one or two albums. I noticed the number of albums is 1 or 2 less than what I had and if I checked on Clean Up Library on Library Maintenance there was some “Clean Up xxx deleted files” and the xxx number is always diffefent everytime I restart.

What I did first is try to restore the database. But, I tried several times but failed with an error message (The error message has a typo as well, “databses” instead of “databases” see attached photo, sorry did not do a screenshot at the time).

I did not know what happened, at one time I did manage to initiate the restore progress but the database did not restore because it happened so fast and no progress percentage was shown and the edit to the database that I did after my last backup was still intact.

I finally reinstall the OS using the latest build 227 and after that I could restore the database succesfully. But even then with every reboot, there is 1 or two album is missing. The only way to regain the missing albums is by manually forcing a rescan on the NAS folder.


Hi @Hogio_Setiawan,

Thank you for the report!

We have filed a ticket regarding this.

Do you know which of the albums are missing?
Are they the same albums each time that disappear?

What kind of NAS are you using?

I do not know which albums are missing. But I think they are different albums because when I look at the “Clean up xx deleted files” in Library Maintenance, the xx numbers vary from each restart and it also vary from each folder.

I use Synology DS-418j NAS. It has 4 drives (3x 8TB and 1x 4TB), 3 of the drives are used for music files and each drive is allocated 2 shared folders. I have tried to force rescan each folder one by one and see which folders and/or which drive creates the problems by looking at the number of “Clean up xx deleted files” change after each force rescan. But, apparently no one specific folder is the cause so I am quite for certain it does not come from any certain drive or folder.

Thank you for your kind attention.

Hi @Hogio_Setiawan,

Can you please share a screenshot of your Roon Settings -> Storage folder?

Also, please share a screenshot of your Overview tab before and after a reboot and note the exact local time + date that you reboot your ROCK at. I can then enable diagnostics mode and see if logs have any further clues.

OK this is what I did.

Yesterday (24th August 2020, 17:30pm my local time) I restarted the Roon OS. After a few minutes, I force rescan all the folders to make sure all the files are accounted for. And then I do a screen capture of the overview.

Just now, 25th August 2020 at 10:00am local time I restarted the Roon OS again and then waited a few minutes before I did a screen capture of the Overview.

However, this time the album is all accounted for. I do not want to do another restart since I do not know what you would do at this time.

The following is my folder structure:

And the following is how I setup the folders in my Synology NAS:

While we’re at it, everytime I do a restart there is always 6 files that are reanalyzed. I narrowed it down to folder \Music-NAS\Music_5 but do not know which ones. This has happened long way back. No big deal, just curious if you also track them down.

Thank you.

Hi @Hogio_Setiawan,

I wanted to check in with you here, is your system still stable following your last message?

If you can reproduce the issue and send me a set of your Roon ROCK logs by using these instructions (Option 1), I can take a look.

I did one fresh reinstall using USB with the latest version of ROCK just for the heck of it, restore the database. And afterward, I tried to reset the database, but I failed again although I could do a restore from a backup. But, I could not reset the database. When I first installed ROCK last year, I played with it to get acquainted with the system; I did a backup, and I did a restore just to make sure that the backup works before I invest more time into editing my database. With last year version, I could do a database reset. Not this year (with the latest update at least).

Other than that, everything works perfectly.

Thank you.

Hi @Hogio_Setiawan,

How did you try to restore the database, did you use the ROCK Web UI? You can also manually start with a fresh database on ROCK by using these instructions:

  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder

Yes, I always used the WEB UI. I did not know about other ways to do it like you just mentioned. Thank you for the information.

Once I restarted RoonServer and restored the database, can I delete the “RoonServer_old” folder?

1 Like

Happy to help, @Hogio_Setiawan!

Yes, once you confirm the restored backup is intact you can remove the Roon_old database location.

Thank you.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.