Problem playing Airplay to Sonos Beam

New problem. When I try to play anything to my Sonos Beam, I get the errors:

Unexpected error communicating with audio device.

Too many failures. Stopping playback.

Using the Sonos app, I can play on the Beam.

Hi @richard_rubenstein,

Was this device already in use elsewhere? If you reboot the Core and the Beam does the issue resolve or are you seeing the same error?

Rebooted the Roon Core (and the PC it runs on).
Unplugged the Sonos Beam, waited 10 seconds, then reconnected.

Ran Roon with output to the the Beam and the same problem occurred.


Roon provides output to a Sonos Beam via either AirPlay2 or Sonos Streaming. I had been using AirPlay2 since, I believe, Sonos Streaming had been problematic. I can still not send music to the Beam via AirPlay2 but I switched to Sonos Streaming and it worked. I did not run it for very long, so there may be the problems we encountered previously. Regardless, Roon can communicate with my Sonos Beam, but not via AirPlay2.

Hi @richard_rubenstein,

Roon does not support Airplay 2 (just Airplay 1) but typically devices should be backwards compatible with the old method. Are you able to play to other Airplay devices okay still? When using Airplay are you just getting the Too Many Failures error?

My mistake, AirPlay1. The Beam is the only Airplay device I have. Yes, when I try to play to the Airplay device, I get what shows in the picture I sent you, ‘Too many failures…’ and ‘Unexpected error communicating with audio device’.

Hi @richard_rubenstein,

I’ve split this out into it’s own Topic because this is a bit different than the issue we were working on before.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs as well as the track that you try to play. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp and track.

6:25 PM CST
Janis Joplin
Track-Move Over

Perfect, thanks @richard_rubenstein — Diagnostics have been enabled so we can see what happened here and I’ll get the report over to the team soon. I’ll be sure to follow up with their feedback as soon as I have it.

In the meantime, just to check — Are you able to play to the Beam via Airplay (I know the Sonos app worked but that uses Sonos streaming) from other sources (like iTunes)?

I don’t have iTunes. I can play using Spotify Connect.

Well now it’s been about two weeks and no response at all from you. I’m very disappointed with your lack of response.

Hi @richard_rubenstein,

We sincerely apologize for the lack of communication on our end. A small clerical error lead to this ticket falling through the cracks. I spoke directly to the QA team about this issue today and they provided guidance on some next steps.

First, the QA team would like to know if you have access to any other AirPlay devices for testing. They believe that the issue you are seeing may affect all AirPlay playback, and that this issue is not specific to the Sonos Beam.

Second, they’ve asked that you reinstall the Roon application to ensure that all necessary components are in place. The logs suggested that this behavior is caused by Roon being unable to locate an AirPlay component that is required for playback.

I uninstalled Roon, reinstalled and it is working now. It is the only Airplay device I have.


Thanks for confirming, @richard_rubenstein. It sounds like somehow an airplay component was missing, but I’m glad things are working for you now. If you see any issues return please do let us know!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.