Problem playing Qobuz content in Roon

I have the same issue ever since I got Roon, but it’s equally unstable with both Tidal and Qobuz. It just randomly stops playing. Sometimes it will play for days nonstop, other times it will play for several hours without an issue until it decides to stop. Or like last night, I started an album and within 3 minutes into the first track, it stopped.

Highly annoying since this is a service I’m paying for that’s supposed to be the “best” out there, yet it’s unstable and has been ever since I started using it.

I’m half tempted to cancel and go with something else at this point.

And no, it has nothing to do with my equipment or network. It has everything to do with Roon.

1 Like

A post was split to a new topic: Dropouts on Qobuz + KEF LSX

Literally just started Chick Corea Chinese Butterfly on Tidal a minute ago, and 15 seconds into the first track, it just stopped.


1 Like

So today… With either Qobuz or Tidal…

Paul McCartney - Flaming Pie
Mojo Buford - Mojo Workin’
Charles Tolliver - Connect

All of these have been coming up “Unable to load track” or “Too many failures to” something or other.

I’ve gone so far as to completely shut down the network, server, laptop and Raspberry for over 15 minutes. All of them completely turned off for over 15 minutes. Come back, get everything up and running and not touch anything for another 15 minutes, just to be safe.

I attempt to play some more albums… Same thing! WTH is going on with Roon?

I am really really close to ditching Roon and asking for a refund. This it totally ridiculous.

1 Like

Well I guess I’m giving up listening to anything through Roon today since it doesn’t want to work at all.

Just started playing on Tidal…

Wilhelm Backhaus - Beethoven: Piano Sonatas No 5, 6, 7, 8.

Once again, at 1:49 into the first track, it just stops dead.

I am sick of this crap.

1 Like

Hi @Charles_Tidwell,

Apologies to hear about the difficulties you’re experiencing with Roon, I’d be happy to look into this further with you. Can you please provide a brief overview of your setup details by using this thread as a guide?

Does this issue impact all of your audio zones, or just one in particular?

Well as you can see in my above posts, those are the issues I keep having. Today, shockingly, I haven’t had a single issue.

I have a Dell laptop running the latest version of Core on its 1TB HD (which is a standard drive, not SSD, with only 83 GB of space used), wired directly to the router via 6’ CAT6. The router is an Asus TR-AC87R. Another run of CAT6, 25’ running to a Raspberry Pi 4 Model B running the latest version of RoPieeeXL. The Raspberry uses a 6 inch USB cable into my Schiit Bifrost 2 DAC. I’m controlling it all via a brand new MSI laptop. Wifi is turned off on the Dell and Raspberry. Only the MSI is using wifi.

Hi @Charles_Tidwell,

Intermittent issues like the ones your experience could be due to your ISP itself, or more likely your ISP’s DNS servers. I would change your DNS to Cloudflare DNS, Quad9 or Google DNS and if the issue re-occurs after that please let me know and we can look into it further.

Hello Noris,

Should I do that to both laptops or just the older one running Core?

Right now, I’m using the Quad9 one. Will let you know how it works out.

Well that was short lived…

After doing that DNS nonsense, and after rebooting that laptop, I started playing Elvis Costello - Look Now… 2:34 into the seventh track, it stuttered a second then stopped… And the Roon screen blanked out for a second as if it was refreshing itself. This is watching from the remote (new) laptop.

I know it’s not the new laptop causing it since you can close out Roon and even shut off the laptop and it doesn’t faze the music playing.

So now what? I’m really annoyed at this whole thing.

And now Tidal again… 2 seconds into the third track of Misha Mullov-Abbado - Dream Circus.

So, so, so tired of this.

It would be the Core computer or perhaps your Router. I’ve not used Quad9, but do use either Google ( or Cloudflare (

Thanks for the heads up.

Listening to it now. :sunglasses:

There no mention of using any of them on the router that I can see.

Hi @Charles_Tidwell,

I would make the DNS change on the router level, your Core is the one actually fetching the content, but if you make it on a router-level then all devices on the network will use the new DNS.

Can you please also send me a copy of your Roon logs by using these instructions? I’d like to take a look to see if anything is amiss.

Link to the log zip file…

Would you happen to know where I make that change in the router? I’m assuming it’s under…

Advanced Settings

  • LAN
  • DHCP Server
  • DNS and WINS Server Settings
  • DNS Server

Hi @Charles_Tidwell,

Looking over the log, it does appear that you are having issues with buffering content, meaning this issue is either networking related or device specific.

08/01 21:50:36 Trace: [Schiit Bifrost 2] [Enhanced 28.0x, 24/96 QOBUZ FLAC => 32/192] [100% buf] [PLAYING @ 6:18/9:38] Blue Soul - Charles Tolliver / Lenny White / Buster Williams
08/01 21:50:40 Trace: [library] endmutation in 40ms
08/01 21:50:41 Trace: [Schiit Bifrost 2] [Enhanced 28.2x, 24/96 QOBUZ FLAC => 32/192] [68% buf] [PLAYING @ 6:23/9:38] Blue Soul - Charles Tolliver / Lenny White / Buster Williams
08/01 21:50:46 Trace: [Schiit Bifrost 2] [Enhanced 28.3x, 24/96 QOBUZ FLAC => 32/192] [38% buf] [PLAYING @ 6:29/9:38] Blue Soul - Charles Tolliver / Lenny White / Buster Williams
08/01 21:50:47 Info: [stats] 6948mb Virtual, 1267mb Physical, 591mb Managed, 7138 Handles, 130 Threads
08/01 21:50:52 Trace: [Schiit Bifrost 2] [Enhanced 28.5x, 24/96 QOBUZ FLAC => 32/192] [22% buf] [PLAYING @ 6:34/9:38] Blue Soul - Charles Tolliver / Lenny White / Buster Williams
08/01 21:50:52 Trace: [Schiit Bifrost 2] [zoneplayer/raat] sync Schiit Bifrost 2 Unison USB: realtime=271830985547453 rtt=0us offset=269476987547us delta=1518us drift=2988us in 396.608s (7.535ppm, 27.126ms/hr)
08/01 21:50:57 Debug: [prebuffer] sleeping in read -- this isn't good
08/01 21:50:57 Debug: [prebuffer] sleeping in read -- this isn't good
08/01 21:50:57 Trace: [Schiit Bifrost 2] [Enhanced 28.6x, 24/96 QOBUZ FLAC => 32/192] [2% buf] [PLAYING @ 6:40/9:38] Blue Soul - Charles Tolliver / Lenny White / Buster Williams
08/01 21:50:58 Debug: [prebuffer] sleeping in read -- this isn't good
08/01 21:50:58 Debug: [prebuffer] sleeping in read -- this isn't good

Have you seen this behavior occurring on any other zones or just on the Bifrost + Pi?

That sounds about right.

Hi Noris,

I would be willing to bet it’s the server laptop and not the network. That laptop is a few years old, uses a regular 1TB HDD, 8GB RAM, 2.1GHz 4-core AMD processor, and can be a little sluggish at times when opening programs and such. However, when it’s just sitting there running Roon Core, it stays right around…

3% - 5% CPU usage
10% - 12% memory usage
2% - 3% HDD usage

It basically just sits there at idle and the CPU fan never comes on unless I get on there and do a Roon update or something.

I pretty much stripped it down to a basic Windows machine, removing any and all programs and apps that I could, as well as manually shutting down all updates and auto-reboots through settings, the registry and command prompt.

After all of that, I ran CCleaner twice, then did a disk cleanup twice, and lastly a defrag twice.

Doing all of that the first time around, I would find that the laptop would STILL DO updates and reboots on its own. After much more research and digging sitting here the past couple of weeks off work, I found a few more things to try (Microsoft is a real PITA when it comes to their auto updates and reboots). After doing this last batch of manual tweaks a couple days ago as well as applying that Quad9 DNS tweak, it seems to have solved the whole update/reboot nonsense.

But with that said, it still randomly stops playing every once in a while, though it doesn’t seem as often, but still often enough.

This morning, just a few minutes ago actually, I applied the Quad9 DNS tweak to the Asus router. Where I tried to apply it earlier (that I asked you about) was the wrong area on the router. While I was on there, I also did a firmware update on it.

As for Roon zones, this is the only one I have. And speaking of firmware updates, I just applied the latest RoPieeeXL update a few minutes ago as well.

1 Like

Hi @Charles_Tidwell,

These are all good troubleshooting suggestions, thank you for running through this list. Do let me know if any of the firmware updates / DNS changes helped with the issue!

1 Like

I don’t want to celebrate prematurely, but so far so good. It’s been a good three hours or so now, and I’ve played five or so different albums, both from Tidal and Qobuz, and no issues yet.

I’ll let you know how this pans out over the next couple of days. Hopefully all of these recent tweaks solves the issues completely. Boy, that would be a nice thought.

1 Like