Problem Running Roon Remote on MacBook Pro


I have been running Roon core, remote, etc. on a Macbook Pro for a while. Let’s call this Macbook1. Recently, I purchased a second Macbook Pro. Let’s call it Macbook2. I used Apple’s migration assistant to migrate all content from Macbook1 to Macbook2. Roon was also migrated and works fine on Macbook2. I deleted Roon and all its associated files that I could find (for example, the “Roon” folder within the “Library” folder) from Macbook1. I then reinstalled Roon on Macbook1 and launched it and chose Macbook2 as my core. However, Roon running as a remote on Macbook1 still lists the DAC that used to be connected to it, but is now connected to Macbook2, as a local audio device. Conversely, it doesn’t see the DAC that is now connected to it. In summary, Roon running on a remote on the machine on which it used to be core, still displays it’s old configuration. It lists a DAC that used to be connected to it, but which is now connected to a new computer, and doesn’t list the DAC that is now connected to it.

How can I resolve this?

It sounds like you did not delete Roon completely on macbook1.
Try removing Roon again from Macbook1 using the following link directions and then re-installing.

1 Like

I’ve deleted the /Users/USERNAME/Library/Roon folder multiple times and trashed the Roon app and reinstalled. There is no Users/USERNAME/Music/Roon folder. Is there any other place that configuration information might be stored?

Hey @Jeff_Steele,

In the same directory as the Roon folder you should also see a RAATServer folder. Try deleting this as well and let us know if there are any changes.


I deleted the Roon folder and the RAATServer folder and the Roon application on both computers. I reinstalled on the new core and restored from backup. I then reinstalled on the old core/new remote computer and have the same situation. The old core/new remote connects to the new core, but displays audio devices as if it is connected to the DAC to which it used to be connected (the DAC to which the new core is now connected). The new remote does not show the DAC to which it is directly connected.

To try to clarify:

New MacBook which is new core: Shows connected devices as DAC, Monitor, System Output, and laptop speakers.

Old MacBook which used to be a core but is now a remote: Shows connected devices as the same as above. Does not show the DAC to which it is connected.


Here is someone having exactly the same problem a year ago. It is not clear if there was ever a solution found:

@dylan @support

Some more information. Checking the RAATServer logs on both computers, I noticed that while both logs show different unique_ids, they both have the same machine_ids and service_ids. I assume that should not be the case. Can you tell me where these number come from so that I might reset them on one computer?

Hey Jeff,

I don’t pretend to understand what all this means, I noticed on my iMac Remote and Mac Mini Core, they only have the same service_id. The unique_id and machine_id are different on the two machines.

Cheers, Greg


Thanks. That’s helpful feedback. It looks like the machine_id has been duplicated on the two Macs. So, if I could figure out how to reset that, it would probably solve the problem.

Hi Jeff,

I stopped RoonServer on my Mac Mini and then stopped Roon Remote on my iMac. I then renamed RAATServer on both machines. I started Roon Server then Roon Remote.

I checked RAATServer logs and found that both machines gave me new unique_id’s, as expected. However, both machines gave me the same machine_id and service_id as I had before. The machine_id’s are different on each machine.

So, it appears on your system, that for some reason RAATServer is getting the same machine_id’s for each computer.

Can you try and delete RAATServer off each machine again, but make sure Roon is not running on either machine?

If this doesn’t work, we will have to leave it to the Roon guys.

Cheers, Greg

Hi @Greg

I’ve tried that with no change.

Well, let’s flag @Dylan and get him back to help.

Just to recap:

I have a feeling that it has something to do with the fact you used Apple’s Migration Assistant and that you still use the original computer. Just my guess.

Anyway, both computers have the same machine_id in RAATServer logs and that could be causing your issues.

Cheers, Greg

Thanks. Yes, the problem appears to be caused by the duplicated machine_id. The machine_id probably relies on a file that was copied by Apple’s Migration Assistant. If @support could let me know how Roon gets the machine_id, the problem could probably be resolved easily.

Hey @Jeff_Steele,

I had a chat with the team about this behavior that you’re experiencing and I wanted to see if you’d be able to perform a test to confirm something for us. It seems that, since the Migration Assistant tool was used to copy one MacBook to the other, the OS is identical on both machines which is causing this behavior.

If you have a device that you have not used the Migration Assistant on, could you try using that device as a remote and see if the same behavior occurs?


1 Like

Hi @dylan

I do have a third MacBook Pro which I already use as a remote and it works perfectly. My original set up had one MacBook as a core and another as a remote. I purchased a new MacBook and used Migration assistant to copy data from the core MacBook to the new MacBook, making the new MacBook the core. Then, I wanted to replace the old remote MacBook with the computer that had previously been a core, making it a remote only. But, I still have the old remote and it still works.

If you could just ask the developers how the machine_id is generated, I might be able to change that and hopefully fix that problem. My guess is that the machine_id is generated from something that was copied by Migration Assistant. I just need to find out what that is.

That post was from me. I apparently logged in with an older account.

Thanks for the info, @Jeff_Steele!

First, may I ask that you once more try deleting the RAATServer folder from both machines? Please give this another go and let me know if you’re still experiencing this behavior.

After some discussion with some of the other support team, we believe that we will need some additional feedback from the technical team. We think that reinstalling the OS may be resolve this, but first we wanted to check with the team. I have filed a report with them and will be sure to update you as soon as we receive their feedback.


Hi @dylan

I deleted the RATServer folder from both machines while Roon was not running on either machine and restarted Roon. The machine_id is still the same on both computers. Can you please ask someone how the machine_id is created so that I can try to change it?

Have you tried making a new user account on the new Mac, say user TESTME, and then running RoonServer under that user on the new Machine? I could be wrong, but, I think the issue is that Roon keys off the actual user account of the machine and you’ve basically cloned that.


When I tried to install Roon as another user, it wanted to replace the existing Roon. So, I did this on my remote machine (which is the old core) because that seemed less risky. Indeed, running Roon as a remote from another user account worked. So Roon must get the machine_id from the user account. When I went back to my regular account and tried running Roon, it went back to how it had been showing the wrong local audio devices. So, while this is interesting in providing diagnostic information, it is not a solution.

I’d still like to see how Roon gets the machine_id (which now appears to have nothing to do with the machine, but rather the user) so that I can see if that can be changed for my regular account.