Problem setting up Network Folder[Solved]

Hi, I just downloaded the trial and entered my network path successfully. However, Roon won’t recognize/accept my network’s username and password.

Any ideas? 14 days is such a short time, and I feel the time slipping away lol


Hey @fore – we’ll figure out what’s happening here, and make sure you get the full 14 days once you’re up and running. Even I can admit Roon isn’t a whole lot of fun if you’re not able to get your music loaded :confused:

Can you let me know a little more information about your setup and your network, and we’ll figure this out? I’d be particularly interested to know how you’re attempting to set up the NAS.

Thanks @fore!

Hi Mike, and Thanks for the help. I’m using 2014 mac mini, and a Synology 1515+ nas. And I’m trying to add the network folders via ADD MUSIC. My path is set at a smb addy.

Let me know if you need more information Mike,


So you’re clicking Add Music on the Overview screen? Are you seeing an error?

If you’re not already looking there, can you go to the Storage tab of Settings and confirm what error you’re seeing?

Also, just to confirm, I assume you’re using a working user name and password for the Synology? Meaning, you can type the NAS drive’s IP address into a web browser and log in?

Yes. I’m seeing an error under the Storage tab. Wrong username or password. And lastly, yes. Though my web address for the nas is smb://xx.x.x.29/musicwaves while the web address thru the browser is smb://xx.x.x.26

Any reason why you’re thinking the NAS has two different IP addresses?

Did you set it up specifically to expose the music folder on .29 ? Have you tried smb://xx.x.x.26/musicwaves ?

No, and now I can’t even find where .29 was on Synology web browser now…fyi, I knew nothing about setting up a nas just 2 mos ago. So much terminology I don’t understand…only had success prob. due to trial and error lol

So I tried smb://xx.x.x.26 And this is the LAN IP address shown in Syn. web browser. So now I"m getting ‘the network path was not found’
Aargh :wink:

Hmm, ok. Make sure you can consistently connect to the NAS via your web browser, and then use the same IP address (adding /musicwaves if that’s where all your music is), user name, and password in Roon.

Also, you may want to try adding directly via the Storage tab of Settings – just make sure you’re setting up a Watched Folder.

Let me know how it’s going and we’ll figure this out @fore!

So aggravating. If I use my IP address, xx.x.x.26 directly to browser, it immediately opens Diskstation and changes the IP to xx.x.x.26:X000/webman/index.cgi in Safari. I tried the above which didn’t work at all. So I then tried again, smb://xx.x.x.26/music waves/32-192 wav

This time, trying to add spaces, which is the way it is in Finder, didn’t help. Still No network found. Should I be using smb on a mac? I didn’t know what it is and looked it up and said it was a windows network something.

Edit: GOT IT Mike! Ok, it was using spaces (missed one above and why that didn’t work) and the full path incl sub directory.
Anyway, I now have all my pcm and dsd/dsf filles imported. Way past time to hit the sack. So can I now have tom be the start of my 14 dys Mike? And now, I need to add the Tidal trial and hopefully that will go smoothly :wink:

Thanks for all the help Mike! I really appreciate it.

Mike, I have Tidal up and running. Everything’s working now…exc. even though all my pcm is in that one directory, Roon only imported a fraction of all my pcm music, and about 70% of DSD files ( I created another network path for this directory).

Any ideas why, or how to fix this and get Roon to recog. all my music? Should I start another thread?


I tried ‘edit network preferences’ under Storage, and simply hit SAVE. It scanned about 10000 tracks, finishes, but then is not imported at all.

Again, should I start a new thread??

Hey @fore – sounds like we’re making progress! We can just continue in this thread.

So, can you let me know a little bit more about the files that aren’t being imported? What type of files are they?

They are all the same 32bit 192 waves

Ok, I just sent you a PM. I’d like to look at one of the files and see if we can get a better sense of what’s happening here.

Do you want the file that was only wasn’t added or one of both?

Hey @fore – I actually just double-checked, and I made a mistake here :frowning: Right now, we don’t support 32 bit files, so I would expect them to be skipped during import.

There’s a high likelihood we will support 32 bit in the future, but the work involved isn’t trivial so I don’t have a timeline to share right now.

Sorry for confusion here @fore – let me know if you want to discuss further.

Ah! That’s the problem, and very unfortunate as the vast majority of my music is 32bit. So far I’ve only scratched the surface using Roon, but it’s pretty cool.

But I’ll have to wait it out till you support 32 bit, and enjoy it for the trial period. I do hope Mike Roon Labs can make it happen soon. Thanks for all your help!

Oh, do you think I can start the trial period today?


Yeah, sorry for the confusion here. Support is coming, but we’re not quite there yet.

If you don’t mind me asking, what are some of your sources for 32bit music? As I mentioned, we are looking to add support in the future, so it would be great to know where this content is coming from.

Thanks again @fore – I’ll follow up via PM about your trial.

Mike, These are simply 16/44 rips to 32bit float 192. I’ve always been very reluctant to rip other than native, but for me, album after album sounded better ripped at 32/192. I was very surprised at this finding to be honest.

Thought I’d just revive this thread instead of starting anew.

Seems by having to use SMB, not all of my PCM files are being picked up by Roons Liibrary Import. Despite all being in the exact same folder.

If I recall, the first time I set it up, and it allowed the drive Volumes/…to be recognized by a simple Add Folder - Browse, all the files were there.

Anyway, I need to find out how to import the rest of my library.