Problem setting up new Lampizator Atlantic DAC with SOTM USB card [Resolved]

I have a Lampizator Atlantic Plus DAC connected to my Windows 10 playback PC via USB cable. I am using the SOTM TX-USBEXP USB card. I am powering the SOTM from an external HDPLEX linear PSU without any molex connected.

I installed the Amamero driver as per the Lampizator website, and in the Roon audio settings it appears as “Combo384 ASIO 1.03”.

When I try and enable this, I get the following error message:

Error: Error loading device info: DeviceInitFailed

EDIT: I tried the DAC in one of the standard USB ports, and it works in Roon. Any idea what is going on with my SOTM card?

EDIT 2: I reinstalled the SOTM driver and switched the USB cable back to that. Now I can still select the Combo384 driver in Roon and change the settings, but when I try to play a track I get a different error:

“Roon: An audio file is loading slowly. This may indicate a performance or hardware problem.”


Is bus power off on the sotm?. It might need to be on to negotiate properly with the DAC.

That red slider beside the power input. You will have to cycle the DAC one more time after turning it on if it was indeed off.

Many thanks for your reply. There is indeed a power bus on the SOTM - something I hadn’t really experimented with. However, I managed to resolve the issue by restarting both the DAC and PC and reinstalling the driver software. I had already tried the restarts, so don’t know why it worked this time - but it did! And now seems to be working without any issue, including with DSD :slight_smile: