Problem with album. Wrong grouping of a song and set on a different album, too!

Roon Core Machine

Windows 10, i3-12100, 8GB RAM
All library on HDD on that PC.

Networking Gear & Setup Details

Speedport 2i as router
Roon Core is connected with Bluesound Node through the router via Ethernet.

Connected Audio Devices

Wired connected (ethernet with Bluesound Node) which does all the playback.
Wireless connection to Android phone and laptop, just for occasional playback and as a remote for the Roon that playbacks on Bluesound Node.

Number of Tracks in Library

~9.000 tracks

Description of Issue

I added the album Down below by a band Tribulation. The band or the album hadn’t existed on my library before. So both the album and the artist were imported for the first time.
Later, from inside Roon, I deleted a few tracks and here is things started to act weird.
Now I have only 4 tracks of this album:

And yet here is what happens on Roon:


There are two instances of the same album! (I only have 1 source, don’t jump into quick conclusions)
But things get weirder:
The first album contains all songs, bu the last one is on a group (for a weird reason)

And the second album contains only that final song!

I removed the folder from source and everything was removed from Roon. I added it again and the same thing happened!

Why does this happen and how can I fix it?
Here is the album on Discogs and there is no grouping etc.

That’s what probably got Roon confused. You can fix it by merging the stray albums.

Damn, that solved it. It was so simple after all. Thank you very much.
The whole grouping of tracks was sorted as I had to manually remove them while I was merging the albums.
I call that solved, but it was a weird situation nonetheless.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.